Underlying connection closed

Hi guys, got this message when trying to run zwift for several times (no success not even when reinstalled Zwift): zwift encountered following error: the underlying connection was closed: an unexpected error occurred on a send. received an unexpected EOF or 0 bytes from the transport stream. if the problem persist (and it does) please contact zwift support.
Could not find any solution here, but noticed same problem occurred few times before. Can anybody help?

Hi @Dejan_Pangersic

Welcome to the Zwift community forums!

The error you are seeing is likely related to an issue with an SSL certificate. I’m not seeing any widespread reports of this, so it’s likely due to some caching issue. I’d like you to try clearing the cache on your default browser and make sure you are using the latest version of that browser. For Windows it’s Edge, for Mac it’s Safari, if you need the steps for doing that this Zwift Support articlehttps://support.zwift.com/en_us/resetting-the-zwift-launcher-H1cPB0v0L has them. I’d also recommend resetting your router just for good measure.

Let’s start there and see how it goes.

Hi Terry.
Did that (clearing cache, browsing history, changed browser, installed latest version of new browser…deleting files, re-installing) step by step and still no success. I’ve already uninstalled zwift on my laptop, installed it on my Pad and iphone. So problem “solved”.
Thank you.