U-turn on Alp was hit or miss

I was using the first leg of the Alp to do 5min VO2max intervals today. I hit 5 mins before the first leg turn and tried to u-turn using the following:

  1. Hit the down arrow on the keyboard.
  2. Hit the left, right, and down arrows on the keyboard multiple times
  3. Clicked up arrow to get the blue buttons on the screen. Selected the blue U-turn button on the screen.
  4. I tried the U-turn icon on the companion app.

I kept climbing the entire time wondering what to do. I reached the turn onto the next leg and hit the down arrow again and it looked like nothing was going to happen. Then my avatar started to drift. She looked like she didn’t want to turn but finally did.

I wondered if mid leg U-turns we’re blocked. But on my next effort up the 1st leg, I blew up, hit the U-turn once or twice and she slowly turned.

So, not a “only turn at leg junctions” feature but something wonky happened today.

Just curious if you knew this was an issue or a thing with the Alp. If you want my logs, let me know.



There is a minimum speed required before you can effectuate a u-turn. It’s 21 kph or 15 mph.

1 Like

Well, that kinda sucks as I don’t go very fast while climbing :cry: thx for the help.

1 Like


I read the requirements slightly differently. Hope this link helps as from what you describe (and how I feel at the end of a 5 minute max effort) I suggest you might not have been going fast enough !!

1 Like

That’s helpful. Thx. I guess I was going pretty slow then because ain’t no way I needed to slow down :joy::rofl::joy::rofl: And I don’t recall being passed. I will pay closer attention next time.