Tour de Zwift emails are not in my preferred language [SOLVED]

I have a weird problem, my emails from Zwift are in french. My weekly update is in English, but the ones regarding the Tour de Zwift are in French. My profile language is set to English. When I log into Zwift or Zwift companion it’s in English.
Has anyone else had this problem and how did you fix it? Zwift support has been no help. they say to go to my email preferences and check my language setting, but there is no language seeting at email preferences.

John O’Dowd

Hi @John_O_Dowd_CRW welcome to Zwift forums.
I let our email communications team know, and yes - there is a glitch in the preferred language attribute on your profile. We’ll get that sorted for you and others that may have the same issue.

Thank you for flagging this up to us!

1 Like

Mines come in Chinees while my profile is in English.