Tacx vortex not being recognised in pairing with wireless ble


(Jacob Rushforth) #1

 I am updated to the most recent software. Using the wireless app to pair the trainer to my MacBook pro, the trainer still won’t show up as a controllable trainer, it shows up as both power and cadence. Any updates coming soon?


(Lennart van der Kamp HIK) #2

I was searching for that too, fortunately my ant+ dongle is on his way but I can only pair as power and cadence. Besides that, the Vortex Smart drops his bluetooth connection with the Vortex Smart, but I already contacted Tacx about that.


(Robert Krüger (BOC)) #3

Same here. Vortex Smart could be connected as Power and Cadence source through Mobile App BLE, but won’t show up as Controllable Trainer.


(Piotr Klimczak) #4

Hi. Same here. Vortex updated, I use mobile app and BLE. I can pair power and cadence, but not controllable trainer. I see it’s a known issue: https://support.zwift.com/hc/en-us/articles/213614686-Some-BLE-Smart-Trainers-can-t-pair-as-Power-and-Controllable-Trainer?section=201540443

@Zwift: any updates on this?


(Conrad Seaman) #5

I have the same issue… in fact it worked a few days ago… then quit again.  I had full control over BLE with Mac Airbook then came back to try again today and it won’t even find cadence/power.  The Vortex app works and other apps work just fine.  


(Piotr Klimczak) #6

Hi @Conrad.

In my case on newest zwift (from 1/29) I also had full control on Windows. I did two rides last week without issues, everything worked perfectly well as controllable trainer.

Now I am on a business trip and I will ride it again during the weekend.


(Conrad Seaman) #7

Piotr,

I seem to have sorted this out for now.  Using the integrated bluetooth on Mac works much better than the Andriod app as a bridge (for me).

The Android App as a bridge seems to have a lot of problems sorting things out and the order in which you pair things seems to be inconsistent.

Integrated bluetooth on Mac seems to work 50/50.  If it fails I just reboot the trainer and app and it will usually be fine the next time around.

In summary - I’m ditching the Android app for now and just using the Mac.  Click on the gear icon to switch to local Bluetooth.  Voila.