Strava uploads missing map and elevation

I’m a long-time Zwifter and sometime in the last 2 months, all my Zwift rides in Strava are missing a map and lack elevation data. Distance, time, speed, power, HR, screenshots all import just fine, it’s just the map & elevation that is missing. Example ride: [insert strava URL]/activities/9024885671.

I’ve tried running Zwift on 3 difference machines (PC, Mac, Apple TV) and it still didn’t upload map data. I checked my Zwift privacy settings and changed everything to public and still no luck. I removed the Strava integration from my Zwift account and then re-enabled it from scratch and still no maps.

So I’ve run out of ideas of things to try, so looking for ideas from the community.

I have not seen this issue on any of my rides (ATV and iPad). Has anything changed in your setup?

Nothing changed from my side, as far as I can recall. I generally don’t fiddle with settings, so pretty sure it was not something I did. At the time I put it down to a one-off glitch but now it’s been happening for a while and it’s annoying not getting elevation data coming through.

I’ve done a thorough google search and nothing similar popped up, suggesting something odd has occurred to my account.

I took another look at the Strava settings and although nothing there indicated blame, I did see the “revoke access” button next to the Zwift connection. So I’ll try revoking, deleting from Zwift, logging out, logging back in and re-establishing Strava connection.

I think I’ve tracked this issue to Strava, as I briefly saw the map on a Zwift ride in Strava and then it disappeared, when I went back to that activity. I remembered I use Activity Fix to automatically set some properties on Strava rides and for Zwift, this meant muting the ride and setting the bike type and ride type to “indoor trainer”. I think this last setting has changed in Strava and it now hides any map data when the activity is set to the “indoor cycling” tag.

I’ve yet to test this, as I only noticed it after my last Zwift ride a few hours ago.

Update: editing any past Zwift ride and removing the “indoor cycling” tag, makes the map and elevation reappear. SOLVED.

Thank you. I came here looking for a resolution and found your solution. Exactly the same happened to me in the last couple of days. I wonder why it is now adding that “indoor cycling” tab, when it’s never done so before. But I’ve got the solution now, thank you.

Perfect. Fixed it for me too. Was doing my nut. Thought I was so clever having the indoor tag, but it’s not!