Still no video replay with ATV 4K

Latest versions and updates. Why don’t I have video highlights or replays for AppleTV 4K? No Video icon in Companion or in-game menus.

I know this was a “phased rollout” but it’s gone past that time I feel like. I’m paying for features I don’t have and I never like that.

How about if everyone had the Climb Portal, but you? Troll.

Which Apple TV model? I believe the 1st gen 4K still doesn’t have it at all due to performance considerations. There are many devices that still don’t have it and some may never get it.

Also keep in mind that at 720p the videos can be of limited use. Maybe good enough for your purposes, maybe not. For me the resolution is perfectly adequate for filing bug reports, but too low to incorporate into YouTube content.

1 Like

Latest info is in this thread. 2nd gen and 3rd gen ATV 4K are 100% rolled out so I’m guessing you have the 1st gen which is 0% rolled out.

1 Like

Thank you, Paul. That’s helpful information. I will check which 4K ATV version I have. I don’t think it’s Gen I but I’ll take a look. That seems like a possible explanation.

What colour/style of remote did it come with? If it was the black Siri remote then it’s the Gen1 4K.

Hi @Mark_Miller5 - as mentioned earlier in this thread, Video Screenshots is available for 100% of the following Apple TV devices:

  • Apple TV 4k (2nd Gen)
  • Apple TV 4k (3rd Gen)

Here’s how to identify which version of Apple TV you have: Identify your Apple TV model - Apple Support

Earlier generations of Apple TVs have weaker and lower-performing processors, which is why the feature isn’t available for all models. However, we are still testing and evaluating performance on Apple TV 4k (1st Gen) - I can’t yet confirm though whether it will be broadly released to that model at this time though.