Still got problems with RPM fluctuations

I posted last week regarding problems i have been having with RPM fluctuations. I have a Tacx Neo and I was having problems since the last update with RPM suddenly going sky high, particularly on the new gravel surface, also on other courses.

There was a recent update, in the last couple of days (which I have installed), and I wondered if that had solved the problem. I did a TT today tough and when climbing out of the saddle my RPM would suddenly jump to about 140 when it should have been more like 70.

Anyway, i just wanted to raise this to see if the persistence of this problem was a known issue and whether it is affecting anyone else.

Which version of the Neo do you have? The 2T has a cadence sensor that is a bit finicky so it could also be a hardware issue, the others estimate cadence based on variations in power throughout the pedal cycle.

(For what it’s worth, I think the road feel got old really quickly and in particular for gravel it is absolutely awful, feels more like destroyed bearings than anything else…)

Hi Anna, thanks for the message. I have the T2800. I have been assuming its a Zwift related issue, as its very recent, and has only occurred since the latest main update. I think its a wider and ongoing issue, as I have certainly seen some other avatars spinning extremely fast! Its not a massive issue, and hopefully it will get sorted out at some point.

Since the recent Zwift update, my avatar starts a ride with legs going like a jet turbine but my actual legs are only doing about 60rpm on a Neo2T.

It generally settles down to my actual RPM after a few seconds.

Zwift haven’t said that they’ve fixed it yet, so I think it’s unlikely that they’ve slipped this in to any recent updates.

Talking of which though, the last update (1.23.3) was on 17 March, when I think pre-dates this issue being reported anyway.

Yes, continuing and unsolved same problem with 2018 Kickr (running on W10) primarily when using erg mode.
Bill Black

Have same issue for a bit of time now, came I think with a few Zwift update ago.
My rpm goes x2 ish and back, even done rides where it dropped to 0 and stayd so rest of ride.
Have Tacx Neo (gen 1), Tacx Ant+ dongle all connected to a windows 10 PC that are fully updated.