Still can't log in or register to zwiftpower

Already second time i post this problem on the forum. When i go to the website of zwiftpower, i can’t log in or even register with my zwift account. The homepage opens and when i click on log in or register, the website shuts down. At first i got a screen with the text: Internal database error. After a few days of waiting i now get a white screen with al lot of letters, numbers en other digits… Anyone knows what this is?

Following as I have not received any answer to this issue either

Tagging @James_Zwift to see if he can help

I was already looking :slight_smile:

I’ll give @xflintx a nudge


Hi everyone, we have a new rider that would like to race with is but cannot create a Zwiftpower profile. White page and site under maintenance? He already did the optin and tried from pc and ipad…
Would appreciate any feedback or hint.


im trying to register and login to zwift power. i am new to the site everytime i try to do it, its giving a blank page with the site being under maintence. i have been trying this for two days i would appreciate if anyone can advise and give me any ideas

1 Like

i have same problem. First it comes: internal database error or i get a white page with a lot of weird letters, numbers en computer signs…

Hi, I 'm having problems to log into zwiftpower
When i try to log in or even register with my account , a text appears: Internal Database Error! After this i can’t go further. Anyone knows of this problem ? Thanks.

Seems fine right now. Give it another try.

Nope, i still got the samen problem. now i even get a white screen with just different digits…

After opting-in to the Zwiftpower connection, I receive the following message when I log into Zwiftpower using my Zwift credentials:

Fatal error : Uncaught Exception: AUTH_PROVIDER_OAUTH_ERROR_INVALID_ENTRY in /app/ext/zwiftpower/sso/decorated/oauth.php:134 Stack trace: #0 /app/phpbb/auth/auth.php(949): zwiftpower\sso\decorated\oauth->login() #1 /app/includes/functions.php(2315): phpbb\auth\auth->login() #2 /app/ucp.php(89): login_box() #3 {main} thrown in /app/ext/zwiftpower/sso/decorated/oauth.php on line 134

I have tried opting-out and back in but continue to receive the same error message.

1 Like

Hi guys,

This is logged into our system and should be fixed this week.


Can you tell us what the problems is?

Hey Zwifters, this issue is fixed as of yesterday afternoon. We were just in the final rounds of testing. For those of you experiencing the issue, please try to register or login to ZwiftPower again after ensuring your account is opted in on your profile connections page.

I’ll be locking this thread now.

If you continue to have issues with ZwiftPower specifically, please write into us at For all other Zwift issues, you can find most answers or get more help at

Thanks and have a great weekend.

1 Like