Speed all of a sudden crazy high

I have been using Zwift for a long time on my ApplyTv with no issues. All of a sudden today the speed was crazy high for no apparent reason and I have been unable to fix it. It has my weight still recorded correctly and the watts, cadence and Hr signals are all accurate but I’m riding 80+ mph at less than 2.0 w/kg. I joined a ride today and instantly rode away from everyone so quit. Then I just rode on my own for 90 minutes and I averaged 1.7 w/kg and went 117 miles. Yeah that’s right, 117 miles in 90 minutes. I’m baffled as to what is going on so if anyone had any suggestions please let me know. That’s the overview now here are a few more details that might matter who knows.

Rode Friday night
Tried to do a group ride and it would not let me in for some reason even though I clicked join event it would say finding riders and never located anyone. Then we tried to connect to my wife’s setup on a PC (my setup is Apple TV) but had no luck there either, so went back to the Apple TV. Since I couldn’t get into my ride I did the Uphill Battle workout instead. I was in no shape for that workout and by the 2nd to last set was doing 40rpm at 130% of ftp. Then I bailed before the last set. Could that have somehow done something? That was the last workout I did which was Friday night, then I joined this ride Sunday morning and the speed was crazy high. I never figured out how to fix it and needed to ride so just rode on my own for 90 minutes and ended up with 117 miles. Please help?

It’s the acceleration bug. Try force closing Zwift on your ATV.

1 Like

Thanks Mike, I’ll give it a shot right after I go Google how to force close an app on my AppleTV lol. But I’ll give that a shot as I am planning on a Zwift ride tonight and report back as to whether that worked for me or not.