Since new update, no Join Now button after 5 min warning for group rides

Hey guys,

Since the update, you can’t join group rides after the 5min warning, no ‘join now’ button in the bottom left corner of the screen…
Or it’s just me???

That is strange.

What system do you use for zwift?

Same that I’ve been using for the last 3-4 years…and had no issues with until the last update…iOS on iPad and Kickr Core
Others had the same issue

The 5min warning comes up, I hit ‘not now’ and can’t join after that…

So you get the “join now” button, ok now i get it.

I have never tried that, I like to get in the pen early to avoid the last minute rush to get in the pen and potentially not make the event.


You can join from the Zwift Companion app.

Nope…tried that as well

Can you screenshot what you’re seeing and upload it here please?

Once I hit the ‘not now’ button when the group ride warning comes up, after that nothing happens, there is no ‘Join now’ on the bottom left corner of the screen. Tried to go in the companion app as well to join, but no avail. A few of us in the group had that issue. Hasn’t happened before and we have 6 group rides every week. Monday was working fine, hit the ‘not now’ and joined in about a minute to go with the ‘join now’ button


To confirm - this is a scheduled event on the Zwift official calendar, yes? Not a Meetup that you or a friend organized?

Also: if this happens again, please take a screenshot using the camera icon on the bottom of Zwift companion’s screen. Another way is to do it the way your smartphone normally screencaptures anything. This image really helps us troubleshoot.

Meet up organised by a friend, but as I said never had that sort of issue before

I was on it this morning and was in a meetup group ride and I also hit not yet and there wasn’t any join now on mine either which was a surprise.

1 Like

Meetups need to start allowing for late joins. We know they are working on some improvements for meetups due to the increase in Zwift users, hopefully they include late joins and more than 50 invites at a time.


We could do late join in on Monday, before the ‘3world’ update. There was no issue with that

Same problem again, after ‘not yet’ on the 5min warning, no ‘join meeting’ on the bottom left corner. Was working fine yesterday’s group ride, same group, same organised.
So today I finished my ride, logged back in, hit the ‘join now’ and apparently I’m in the group, but no zwifters around me, group timer is going up top as normal, my name is green, and the other guys are riding for sure…

I ran this thread past the game devs. Late join has never been a thing in Meetups. They think the thing you’re calling a late join is the 2nd callup to the start line.

That said - the devs are working on improving the Meetup feature as we speak. One of them is a late join feature, and @Mike_Rowe_PBR, the other thing is increasing the Meetup cap beyond 50 people.


Great to hear! Next on my wish list is being able to turn on and off “keep everyone together” for the sprint and KOM segments similar to how event leaders can turn the fence on and off.

Thanks @shooj and the Dev Team!!

1 Like

Thanks mate, I could late join the meet, yesterday in London, but not today in Watopia,
Hopefully it will be a standard feature

I had the same problem today. I started a ride thinking the Join Now” option would come up but it never did. Finally had to log off and start another ride. This was for the SRAM women’s ride.

1 Like