Screen glitch in large events for macOS [October 2022]

Is anyone else having this issue where using Zwift on a Mac the screen starts bugging out in events with larger fields like the images posted?

I’ve not had this issue until fairly recently and now it seems to happen on the regular. Tried a fresh app install and no joy. Be great if anyone that’s had this has a solution.

I’ve not made any changes to my mac software at all so feels like it could be app side :man_shrugging:t3:?

1 Like

Thanks for the reply, this is happening on any course where there is a large group event. I did notice it initially in Makuri but it’s not isolated to there anymore. It’s not a quick thing either it goes on and off for a fair while.

This link shows it happening in this case on R.G.V


I’m not saying the game should be going all disco lights but your video is like a Powerpoint presentation. What Mac is it?

Yes, I noticed this a few weeks ago in Neokyo riding solo. I’ve only experienced in Neokyo/Makuri Islands but it’s pretty consistently an issue there. I was doing a short lap and it happened in the same spot on each lap.

Hi Dave,

It’s a 2018 15” MacBook Pro

Not the best for streaming but I wanted to try capture what was happening. I had the same thing again this morning on R.G.V on the 3R Endurance Ride. Large field of around 150. At its worse the whole screen was glitching out as we went through the whole length of the pave sprint.

All I’ll say it’s a good job I don’t suffer with epilepsy! - it’s getting a bit frustrating now, it was absolutely fine until the recent updates. :man_shrugging:t3:


Yep… Exactly the same issue for me, especially in neoyoko.

It began months ago, yet has started to infiltrate other maps now. It usually starts with the map flashing in the top right hand corner.

If you screen shot it through zwift, and then upload without the graphs and data, the graphics look perfect. Yet turning the HUD off during the ride makes no difference.

It’s definitely worse in group rides rather than rolling with pace partners or free riding.

I feel your pain…

1 Like

Yep that’s exactly how mine starts each time and then gets worse. Hopefully @shooj can point this in the direction of someone in technical that may be able to help. It’s not a great experience to have to put up with this each time I ride in a group or race.

Mine’s doing exact same thing. Been awful the past week. Thought it was to do with number of people in the pen as was way worse when there was over 100 people in a race

Yea it happens for me if the field is quite big for a race or group ride. When the field is around 30-50 I don’t notice it so much. :man_shrugging:t3:

happening me too… started 2 weeks ago.

really bad today. not consistent but would say more aligned to large group rides though happened when solo too.

@D_anno_Race3R @Cody_H @PhilBanks @Mike_Ellington_R3R_D @Nick_Midgley

Shuji at Zwift HQ here. Thanks all for flagging this up. Screenshots are super-helpful so thanks for those especially.

I’ve flagged this up to the team for investigation. One commonality I noticed among all of you is an Intel-based Mac with AMD Radeon graphics, which makes me wonder if a driver needs updating / rolling back.

In @D_anno_Race3R 's case - there are two GPU’s installed per this image.

Can I ask all of you check your GPU spec and post the screenshot? On my end - I can’t see if you have a dual-chip graphics - I can only see the one that’s being used at the time. If yours is a dual-GPU machine - please check if Zwift is set up to use the dedicated graphics card per Apple’s support site?

If you check the other threads about these anomalies, there are Apple TV users as well.

Also this gentleman said “new mac mini” - presumably M1 (?) but not stated

Hi Shooj,

Thanks for following up.

My specs are pretty identical to Danno’s. I’ve tried both discrete (the additional graphics card) and intergrated, yet it makes zero difference. Just in case you don’t know (although I feel sure you will), graphics drivers on Mac’s aren’t updated the same way as on PC’s, you can’t roll them back easily. Also, Zwift doesn’t force the Mac OS to use a discrete graphics card over the integrated one as standard (things like photoshop do) you have to do that manualy though a setting in preferences, or an add-on called g-switch (it’s been recommended by mac help before when trouble shooting a different issue with them).
Hope that helps with the picture.

Thank you for following up, @shooj. Here’s a screenshot of my Mac’s specs. My Zwift experience has always been top notch on this machine until several weeks ago when these screen glitches started. I thought maybe the graphics card was on its way out and was maybe too taxed so I toyed with reducing Zwift resolution in settings, but that didn’t prevent the issue.

Thank you so much for posting this. I searched everywhere for someone experiencing what I’ve been. I very recently switched over to using my iMac, 27" - using an HDMI cable with compatible thunderbolt adapter to connect my 75" TCL as a separate display. The graphics card I’m using is a Radeon Pro 580x. The problem has a strong correlation to the size of the group, as another user points out. If the group is relatively small (below 50), I have zero issues. But if there is a severe “crowding”, as noted in Zwiftalizer - I have the same issue.

Here’s my screenshot….


Hi Shuji,

One more thing… mine says that zwift doesn’t require high perf graphics card… not sure how to change it or if it should?


Folks - make sure you hide your serial number! People will use it for bad purposes.

None of my Macs are doing this, but I have only single GPU (not an integrated one).

Main Zwift machine:
Monterey 12.1 - Xeon X5690 6 core 3.46ghz
32GB 1333mhz DDR3
Radeon RX580 8GB

Other desktop:
Ventura 13.0 - Xeon W3245 16 core 3.2ghz
48GB 2933mhz DDR4
Radeon PRO W6800X MPX 32GB
1TB SSD (T2)