Run Route Completion Bug

Mayan Bridge Loop. As I was getting close to finishing the route, the distance countdown went from 0.3km to 2900m rather than 290m. Finished the route per the route completion bar, but still 2600m on distance countdown. Ran the extra 2600m but never got the route achievement badge. Who cares. But there is a programming glitch.

See the following threads:

Thanks. So why is it still a problem?


I don’t work for Zwift. 99.9% of posts on the forums are from users and not Zwift employees

I appreciated that you are another Zwift user trying to be helpful. My question was rhetorical. One of the posts to which you pointed says this issue was fixed by the release on April 22nd. Yet the glitch turns up again on May 16th. Thank you for bringing these related posts to my attention.

Note that this was on a PC and hence should have had the latest updates; so maybe the bug wasn’t fully fixed in the April release?

I ran the route pre and post fix on a Windows setup and can confirm it’s fixed.

Or was…

When I experienced this glitch (May 16/22), it was on a current gaming laptop running Windows 11 immediately after installing the latest Zwift update.

That’s bizarre. I wonder if the update didn’t apply correctly. Can you run the log file through Zwiftalizer in order to work out what game version you were running?

Someone posted about this on the ZLDR Facebook group a couple of days ago. They had the current version of Zwift. So I guess the fix applied in a previous patch has been cancelled in the latest update.

I ran the route again this morning… The distance countdown goes from 0.1km to 2626m.

Did it route you around the full Jungle lap rather than across the new Mayan bridge by any chance?

I’m using AppleTV, which auto updates, so I’m on the most current version of the app. I’ve run the route twice over the past few days and have the same problem. Today I actually ran the route for about 6.5 miles. After the 2nd time through, the meter countdown stopped and altogether. I was planning on contacting support, but figured I’d check the forums first, to see if anyone else was experiencing the same problem.

1 Like

Mystery Solved. See the comments on this route descriotion on ZwiftInsider where the problem is identified and a workaround provided. It seems that Zwift is taking us to the right at a crossroads 2.1km into the route whereas the route actually goes left. I looked at the traces of my runs on this route as auto-guided by Zwift and compared them to the official route. Sure enough, Zwift guided me right at 2.1km when I should have gone left. I am going to self guide myself around the route tomorrow so I can finally get this route badge.

That’s the workaround that sorted it but it was definitely fixed in the April release.

Really odd it’s reverted back in the May update.

I contacted support after my earlier post. They noted the following, “We’ve received reports about this issue where some Zwifters are being rerouted when running Mayan Bridge Loop and aren’t being awarded the route badge. We’re working hard to get this fixed as soon as possible.” Seems that not everyone is having the issue. Hopefully it’s fixed soon.

Interested to know if the self-guided run of turning the opposite way at the 2.1k mark definitely works.

1 Like

It was reported to work as a manual fix. Like I said I ran the route prior to and after the alleged fix and it was working but now appears to not be the case.

The glitch seems to have been fixed today, May 19/22. The incorrect turn glitch at the crossroads to the Mayan Bridge (turned right instead of left) was still there when I tried to run the route on May 16 & 18/22.

So I finally got the Mayan Bridge Loop Achievement Badge. However, note that you have to run a total of 10.9km. The Lead-In is 5.7km. After you complete the lead in, the progress bar will show Complete. However, you still need to run another 5.27km!!!

One of those posts has now also been stickied at the top - they are aware of the distance issue and is working on it.

I just ran the Mayan Bridge Loop but was routed completely differently - up the KoM reverse - thankfully not round the radio tower…

That can’t be right :frowning: and no route completion… didn’t even see any parrots!!