RPM Registers But Says Zero

I have a Wahoo Blue Cadence Sensor and Kickr Snap trainer. My Kickr registers. Watts register. Seed registers all on pair screen. My Wahoo gets picked up, is paired as indicated by blue lights on the sensor. But RPM says Zero on Pair screen. In game RPM way off. Seems to be causing issue in training mode and less on a ride.  I have all other bluetooth off in room.  I usually use Apple TV app and tried using macbook pro.  No change.  Also changed battery in Wahoo Blue.  No change.  This seems to be related to my issue of the resistance being beyond difficult in a workout mode (i.e. FTP Test) vs in Just Ride mode.  In Just Ride mode all feels normal, but in FTP Test the resistance is insane and RPM is way off.  

Hi Craig, Just as an aside, is the ‘Controllable Trainer’ option enabled?

Hi Paul…yes, it is  I’m wondering if the life of the Wahoo Blue is over?  Thinking to try to purchase a new one to see if that does the trick.  Totally baffled.  Should pair up easily.  

You could be right Craig, the Wahoo Blue may have quit negotiating :frowning:

If you decide to replace it, Wahoo’s later sensors are Bluetooth and ANT+. If you were to get an ANT+ dongle for your Macbook Pro you’d have a double set up. ATV and Mac.

I always recommend using ANT+ if possible, your Kickr and the new Wahoo Bluetooth/ANT+ sensors work well in an ANT+ environment.


I have a similar problem with my wahoo cadence sensor, pairs OK then keeps dropping out. This was Wahoo’s response, but it hasn’t resolved the issue, I need to get back to them. I’ve also tried a new battery but to no avail. I was wondering if it may be I’m too far from my wifi box?


Melissa Ake  (Wahoo Fitness Support)

Jan 22, 9:23 AM EST

Hi Claire,

Thanks for reaching out to us! I’m sorry to hear about the cadence sensor troubles. You’ll want to make sure that there are no other apps trying to pair to the sensor while you’re using it with Zwift (apps in the background or running on your phone). Try forgetting the pairing from Zwift, then restart your iPad. While it’s restarting, reset the sensor by removing the battery, installing it upside down for 30 seconds, then reinstalling in the correct orientation. When your iPad boots up, pair the sensor back to Zwift (again make sure there are no apps open on your phone that are trying to pair). Let me know if this doesn’t get you up and running!