Ride-On bombs flaky since 3 December 2018 update


(Jim Mattson) #1

Many times over the past few days, I’ve punched my arrow on the ZCA map when encountering a new group of riders, and…fizzle. The perimeter circle goes away and slowly refills as the next Ride-On bomb arms, but no Ride-Ons are given out. If I try again after re-arming, a handful of Ride-Ons might go out, or they might not. Checking on individual nearby Zwifters, I can dole out Ride-Ons one-at-a-time, and that still works fine.

Is this a bug, or have Ride-On bombs been nerfed deliberately? Just curious.


(Vincent) #2

Investigating! Edit: Are you Ride-On bombing on PC or iOS?


(Jim Mattson) #3

I am Zwifting on Windows 10, using ZCA on iOS to Ride-On bomb.

Note that I’ve been seeing the same problem both before and after the 6 December 2018 ZCA update. It all seems to have started with the 3 December Zwift update.


(Aaron Zwanzig) #4

I can confirm that Ride-On bombs are inconsistent. I noticed when I recently hit Level 12 and started climbing Alpe du Zwift. On my descent I like to bomb the climbers that I pass using ZCA on an Android device. When I hit my arrow icon on the mini-map the circle representing the effect area pulses and fades and the recharge timing circle runs, but I see the thumb icons representing Ride-Ons issued appear in the mini-map about half the time.

Edit to add: I’m running Zwift on ATV4K along with ZCA on Galaxy S7 Edge.


(Vincent) #5

@Aaron_Zwanzig and @Jim_Mattson what could be happening is that you’ve already given Ride On’s to people in that same session, so the Ride Bomb won’t “affect” those same Zwifters. Ride-On bomb’s take into account people who are close to you and who haven’t received a Ride On from you that session,


(Jim Mattson) #6

Nope. That’s not it.


(Aaron Zwanzig) #7

I don’t think that’s the case here. I don’t generally give ride ons to people descending while I’m ascending. So the ride ons i give while descending would be new and unique.

Maybe the timing and lag between the ZCA and the main game servers has something to do with it. If I’m passing them at 45mph it’s conceivable that by the time the game registers that i sent a ride on bomb, no one is still in the effective vicinity for it to affect.


(Aaron Zwanzig) #8

The bombing function worked pretty good today. I bombed 20 or so times and only had 2 or 3 duds.


(Jim Mattson) #9

The problem appears to have been transient. Things have been working normally for me the past few days.


(Jason) #10

I run Zwift on Windows 10 on a PC and use the Companion app on Android (Galaxy S5 with Android 6). I have always (since the Ride on bomb was first introduced) noticed that some Ride On bombs work and some don’t. Also, the ones that work sometimes give out 5 Ride Ons and sometimes less. As I said, this has always been the case and it happens even when I am among hundreds of different riders going in both directions so the list of riders nearby is constantly changing. I can check those riders and see that many haven’t received a Ride On from me and yet the Ride On bomb still does nothing.

It’s as if you run out of Ride Ons for a period of time. Maybe Zwift doesn’t want Ride On spammers cruising around dropping big blue thumbs on everyone. Kinda defeats the purpose of having the Ride on bomb though.


(Vincent) #11

Thanks for your feedback Jason! We’ve tried to pinpoint the issue and have had trouble, but we’ll investigate to see if Ride Bomb’s are a little wonkier than previously thought. There is a cool down period with Ride On Bombs as well.


(Aaron Zwanzig) #12

In my climb up Alpe du Zwift on Tuesday, ride bombs and individual ride-ons (where you tap on a blue dot in the companion app map and select the ride-on thumb) worked for the first half hour or so. After I had been climbing a bit I noticed that all ride-on functionality had failed. All bombs were now duds, and when trying to give individual ride-ons the thumb was gray for everybody even after keeping them selected in the app for several minutes. I did, however, continue to receive ride-ons from other riders.

Perhaps related to this, or not, that particular ride did not count toward my Wahoo climbing mission.


(Jason) #13

Thanks @Vincent So Ride On bombs have a cool down period!?! Interesting. That probably explains what I am seeing. So unlikely to be a bug in my case.

Why have a cool down period though? Not sure I understand the logic of allowing me to easily give Ride Ons to the first 20something random riders I ride past, but not to the next 20something random riders. What is the reason for this?


(Aaron Zwanzig) #14

The cool down period is the time it takes for the little white circle to be drawn around your triangle icon on the map.


(Jim Mattson) #15

I noticed some flakiness with Ride On Bombs doing the Innsbruck KOM this morning. I was moving slowly, so a lot of groups passed me. As they passed, I would bomb them. Several bombs were duds.


(Jim Mattson) #16

Still seeing a lot of flakiness with Ride On Bombs.


(Jim Mattson) #17

Things seem quite a bit better since the last update.