ride does not upload to Garmin Connect

A number of previous Zwift rides have uploaded to both Strava and Garmin Connect. The Garmin uploads lack elevation, but that is easily fixed by the known FitFileTools and selecting the Garmin Edge 500 or 800 as gps. However, today for the first time, the file uploaded to Strava just fine, but did not upload at all to Garmin. I tried the standard manual upload to Connect and received the following message in red. “An error occurred with your upload. Please try again.” I tried with a new file from Zwift, and a file from Strava, with no luck. What am I doing wrong? Or has Garmin decided they don’t want Zwift .fit files?

Try disconnecting & reconnecting Zwift and Garmin. 

Hello all,

Here is the fix, as determined from the Knowledge Base after a discussion with Jessica. Using fitfilefix, change the time stamp, then change the device to a Garmin Edge 500 or 800.

1 Like

That worked for me. I wondered what was going on as my last (and first!) ride a couple of weeks ago synced up straight away. I hope they can get this fixed :slight_smile: