Require Assistance as Resistance is Futile

My friends, I have a strange problem. I have a Flux 2 that works great on the Tacx App. Also, my father rides it when it is not connected, as many of you know, that is a feature of this trainer, and he says he’s not noticing anything.

Now, for the problem: When I ride in Zwift, my ~0 grade riding has almost no resistance. That is to say, on flat, or basically flat ground in Zwift, I have to ride in the absolute lowest chainring just to move practically. Any other gear and I’m just spinning against air.

With the make of the Flux, and considering this is only a problem, so far, on Zwift, I was wondering if anyone has encountered this, or if anyone has some suggestions.

My set up is basic: Flux 2, with an Edge 530 headpiece (usually not on when I ride Zwift) and I connect through Bluetooth. I’ve noticed this both on my Android tablet and my Windows 11 laptop.

Thanks for reading, stay true, and I look forward to any advice!

Make sure that head unit is not taking control of the trainer, go to setting in the EDGE and remove the trainer.

if the Garmin Edge isn’t the issue, maybe the tacx app is? Make sure that is force closed too. There is another Garmin app, Garmin Express that can also interfere with Zwift, if you have that installed on the PC then make sure to close that app as well in the system tray.

1 Like

HI mates, great suggestions! Ok, so strange story, I was riding Zwift AND the Edge was connected…, and if I changed the resistance on the Edge, it changed the resistance in Zwift! So both were connected at the same time!

Interestingly, and perhaps a culprit in the lack of resistance, is that the natural setting of the Edge’s resistance is ZERO to 12 or something!

But here’s the kicker, when I don’t have it on, and even after making the Flux no longer connected to the Edge, and after I cleared all the data (overboard perhaps), this lack of resistance is still there!!

Thanks for the read, and any and all help is greatly appreciated!

I thought you had a Tacx? :wink: j/k

Are you pairing the flux as power and controllable in the pairing screen?

1 Like

Lol! Mike, I almost “went there” but didn’t want to confuse any speedreaders, through be glad it’s been done!! :stuck_out_tongue: :smiley:

Yes, that’s what is so strange about this - the Flux IS connected as the trainer and is the accessing the “control” setting. But despite it being the controllable one, I swear the Edge was affecting it too!

So could the Edge still play a role, and it the trainer(and its power curve likely) was altered by the Edge, would those alterations be there even after the Edge has been whped?

I find it interesting that my resistance is so low AND it’s at the “zero” bar on the trainer, AND changing the resistance on the Edge changed it in the game.

Also, My hills all have an impact on the resistance, so the game is still controlling it too!

Thanks for the help mates! Any and all suggestions wanted!

Can you post a screen shot of your pairing screen in Zwift?

1 Like

See this thread:

I was the dummy. Don’t be like me.

TL;DR: there is almost certainly some app or device that “remembers” your trainer and is attempting to “steal” control in the background.

Fitness apps are “greedy” - they want to run in the background, ostensibly to ensure activities are captured even if they’re not in the foreground.

On your bike computer, find the Flux in “Sensors” - there will be THREE: Power, Speed/Cadence, and “Controllable.” Switch the “Controllable” sensor to “OFF” to ensure the bike computer can’t send commands back to it.

In the Tacx training app, you can manually disconnect from the trainer.

Howdy all! Great thread to go over, C.J, I’m sure I’ll find some great stuff!

Also, here is the screenshot of the Flux in control despite the Edge controlling it. I think the Edge is doing it over ANT and Zwift, bluetooth! Thanks for all the amazing help so far, please add anymore suggestions if you think they’re helpful!

1 Like