Problem connecting with Quarq Powermeter using Garmin ANT+ stick


(John Powell) #1

I have the older Garmin ANT+ stick (longer with rounded ends) that I’m attempting to use with my Quarq Riken powermeter. I’ve read on the forums that others have successfully used this setup, but Zwift won’t discover my powermeter when I attempt the same.

The powermeter regularly connects to my Edge 510 with no issues. I’ve used the ANT+ stick to successfully download data from a FR60 sports watch.

Details:

• older Garmin ANT+ stick (longer with rounded ends)
• Quarq Riken powermeter (fresh battery, operating normally)
• MacBook Pro Retina running OS 10.10.1

Any suggestions?


(Jon Mayfield) #2

Check the back of the dongle and make sure it says “usb2” on the back. The really old non-2 dongles won’t work.


(simon orange) #3

I know it’s of no real help but I’m using the olderstyle big garmin ant+ stick and a quarq but on a windows pc and it’s working fine.

have you tried a usb extension lead to get it nearer the crank ?
are you using any other ant+ devices (HRM?) and do they work ?


(Ed Aguayo) #4

I have a similar problem. I am using Windows. I have the same dongle (it is the USB 2.0 version). Except I have a PowerTap 2.4. The software looks for the power meter but doesn’t seem to be able to find it. If I unplug the dongle it says the dongle isn’t there. So, it is finding the dongle, but it can’t connect to the power meter. I am trying this being right next to the meter, so I don’t think it is an issue of being too far from the power meter. Any tips on solving this issue would be greatly appreciated!


(John Powell) #5

It’s the USB1 version of the Garmin ANT+ stick. Proximity didn’t help, so it looks like I definitely need to get a new one.


(Jeff Hirsch) #6

Have you tried popping it out a couple of times?

I have both a usb2 and usb-m version and every once in a while I have to pop it out and let it get recognized again before it will pair.


(Joe G) #7

the service for the Garmin ANT+ stick is grabbing your device, you need to stop the service or remove the software but leave the driver behind to talk to Zwift.


(John Powell) #8

I’m not sure how to disable or remove the service on OSX without removing drivers.


(Jon Mayfield) #9

On mac we shut down garmin software before running Zwift so that shouldn’t be the problem. USB1 sticks do not work with Zwift, so that is almost certainly the issue. They must either be a small usb stick like the usb-m or they can be the old long rounded ones if they say USB2 on the back.


(Christian Lyra) #10

I have the old one too, and it has “USB2” writen on the back. But zwift cant find the dongle. The Mini mac never saw the garmin software as it’s the one I use as media center. But… I’m using the OSX 10.9. I will try to upgrade and see if it helps.