Picking up cadence but no power [SOLVED]

Has anyone else had issues when connecting their Elite Zumo and it now showing Watts and therefore your avatar doesn’t move?

I have tried with both bluetooth and Ant+ and it connects with both but once in-game it registers the cadence but on power and therefore the avatar won’t move and just sits on the side of the road.

Any help or troubleshooting suggestions would be much appreciated. Thanks

Tell us more about your setup. What sort of device are you connecting to?

Elite Zumo should work fine - I use one connected via BT to AppleTV.

Hi Steve,

I’ve tried via my HP laptop using bluetooth and Ant+ doggle, my Samsung s8 and my partner via her iphone 11. All do the same, connect but once game starts no power and no rider movement.
The power says it connects but never shows any watts even in the connection page.

This will happen if you have multiple devices logged in to the same account simultaneously.

Please make sure you’ve logged out of the app on all devices by 1) saving & uploading your session or 2) trashcanning the session. Swiping the mobile app into the background isn’t the same as logging out.

1 Like

Thank you, we think this may have fixed it as we are now able to get it working with power!
My partner’s work laptop was logged into it and once uninstalled it came right. Cheers.

1 Like