Overwattage with vector 3s

Hi, I have new Garmin vector 3s, with Garmin connect on my Iphone. All things are updated, I have reinstalled the device many times but once on Zwift, I still have anormaly high wattage value (FTP 430). I have read on different forums but I did not find a valuable answer to fix the problem. Any advices?

Couple of thoughts to get things started.

Have you tried zwift on a computer?

Do the pedals read high on the road?

Have you zeroed the pedals?

Hi Hugo!

I remember with my old garmin vector 2s which had the pedots they had to be tightened to a specefic torque to give out the correct data but I know that the vector 3s dont have pods and might be different (just a thought).

Also another thing I can think of is change the position of your setup as there can be some form of signal mixing thats making it go all over the place. This happens with me when I place my trainer on the balcony for example I get insane power numbers which is so weird.

Another obvious is firmware update the pedals and make sure the crank length is correct (written on the crank).

Hope this helps

Hi Ben_Brawn! Thanks for your response! Yes, Zwift is on my computer and the pedal have been « zeroed ». I did not tried the pedals on the road. I dont have gear to capt power in the road. I have a vivoactive 3 watch and I found only to late that my watch canot read power pedals. I wanted to use the vector 3s for a more precise Zwift pre-season training. I’m thinking of letting a friend with a another powermeter use my pedal to compare wattage. Thanks for the advices, I will continue searching and I will post my findings later!

Hi AINaber I’ve « undressed » all gear except the pedal. Took battery out, reinstalled the gear on Garmin Connect. Will try to compare data with friend (in a covid 19 safe maner!) with another power mesurement gear and will adjust the values in garmin connect.

Crank lenght is good also!

hmmm do you have a bike computer? Like I have a whoo and rezero’ing from the unit itself is a good idea also…

Just trying to come up with solutions…

No, he just has a watch that doesn’t read power.