RPM but no watts using Vector3 pedals

I’m new to Zwift, have a Kesier M3 spin bike with Garmin Vector 3 Power metre pedals. Zwift is on an IPad Air with IOS 12.4.5 less than 1m from bike. I can pair the power metre Via Bluetooth and see RPM but zero watts and my avitar doesn’t move. Once ore twice I have had some watts but only for a few seconds and only when standing on pedals not sitting. Any assistance or ideas much appreciated. Thanks

Do you have the Vectors paired as your power meter? Can you post a pic of your pairing screen?

Thanks for the reply. This screen?

image|320x240

Yes, that screen. But can you post one that is not blurry (it may need to be higher resolution) and taken while you’re pedaling?

Is this better?

image

When you click power source and pedal are there other options?

No. No other options. I can get cadence but no watts.

Im assuming these pedals have worked on other devices? Garmin head unit or phone app? I don’t have these pedals but generally the advice is make sure your power meter firmware is up to date. Unpair it from everything (Bluetooth devices only allow so many connections). Unpair cadence, try to connect just power. And if possible use a device with ant+.

Yes. They’ve worked with a previous owner. It connects to the Garmin Connect App ok. Firmware is up to date. I’ll need an Ant+ adapter. So will try that. Thanks.

Try unpairing from everything first (phone app, garmin head unit etc).

There’s also an old post here about the same issue. They suggested the pedals needed to be recalibrated.
https://forums.garmin.com/sports-fitness/cycling/f/vector-3/141573/no-power-just-cadence

1 Like

Appreciate your suggestions. Thanks.

So… now getting watts and cadence but the watts is much lower on the Zwift reading than the Keiser computer. 200 v 80-100W. Getting closer!

So the Keiser computer reads from the spin bike not from the vector pedals?

Sounds like one of your pedals isn’t sending power data so you only get half your power. Can you use your phone app to tell you left right balance?

If this is the case I see people have had this problem for a while (the last comment is useful) Garmin Vector 3 power way too low

And Garmin has a suggestion page about it https://support.garmin.com/en-AU/?faq=8XvDuPCDpD6MDaAqTuHyy8

I’ve also read that you need to be careful if you take the battery cap off. When you re tighten them people have stripped the thread easily so be careful and look up what torque it should be.

1 Like

Thanks again for your help. Will continue to tinker.