No sunlight on rider since TOW update

Yes It started when France was introduced and it is slowly making it’s way into all the other worlds. I don’t like the look of the Rider always in the dark. I am sure there is another post about this.

1 Like

It was a ‘thing’ on iPadOS for some months starting around Nov 2021, but I don’t recall ever reading about this happening on PC in the last 18 months.

2 Likes

Thanks Jeff, you understand me :wink:

I checked it on Android, no problem there with the lights. Shadow only happening on PC for me.

1 Like

Im in the sunlight on windows 10, no issues here. Maybe you need a reinstall, something got corrupted during the update?

1 Like

Thanks for your feedback Mike. Already reinstalled without success. Maybe depending on specific CPU/GPU. Running AMD here.

Real world is in shadows too at the moment. So this Zwift “problem” can not be so important. I will wait until next update and see if it changes back to normal then.

Ahh, yes, AMD has some issues with Zwift. Something about the drivers not playing well with openGL games.

@Marcello_Gottardo

I would also assume that the AMD GPU is the culprit. Have you tried updating the graphics driver? If the driver is current, possibly rolling back to the previous graphics driver will make a difference?

1 Like

Thank you Steven, I will try this in the next days and report.

Hi @Marcello_Gottardo

You’re welcome!

Since you first reported this issue, I’ve seen at least one other report of the exact same issue. Further investigation on my part has revealed that in both cases the “no sunlight on the avatar” issue has occurred on a Windows PC with an AMD CPU and GPU.

Since this appears to be a budding trend, I’ve flagged up the matter to a higher technical authority of the team and I’m waiting to see if we can get an official bug report. Thanks for your efforts in reporting this!

1 Like

Hi @Marcello_Gottardo

I heard back from the team and got official word that we now have a bug report for this issue. It’s with the Zwift dev team and they’ll be working on a fix.

Thanks again for your help in reporting this issue; it’s appreciated!

image

2 Likes

It doesn’t work on apple TV either, I think I read someplace its a IOS issue mostly? Not sure but yeah, I don’t have the shadow either.

Hi @P_Allez

Thanks for letting us know!

I’ve gone ahead and updated the team so they’re aware that the issue appears to be impacting Apple TV as well as PCs with AMD graphics cards.

1 Like

Hi Steven

Indeed upgrading AMD grahics card driver solved the issue!

Upgraded to AMD Radeon Adrenalin 21.5.2 driver (released 06/21/2021) and the sunshine came back :smile:

(maybe good to know: When starting new driver installation, old driver will be removed in a first step. After restart, system remains with a standart windows driver. Start installation again, and new driver will be installed then. Again restart, and everything is fine).

Thanks for your help and happy zwifting!

Now let the sun shine upon the whole world.

Hi @Marcello_Gottardo

This is great news! I’ll update the team and hopefully others impacted by the issue (who also use a PC with AMD graphics) can resolve the issue by taking similar action to yours.

Have fun riding in the sun!

1 Like

This thread is about the rider and surroundings being in permanent shadow. I’ve never seen that on Apple TV. Are you sure this is what you’re seeing?

Apple TV doesn’t have a shadow of the rider on the road as you ride along, but it does have shadows of trees and other such scenery.

Yep, I will get a screen shot when it happens again. After I got apple TV when there are LOTS of people in the group like stage 2 of TOW I think it was the graphics were all jacked up. Not sure because of the number of riders in the group or what. This doesn’t happen all the time on ATV for me but happens. There are non-shadow on the rider still.

But for this topic my guy looked like the OP’s. Again its not always but it happens.

I will say also it didn’t bother me and I was surprised I actually noticed to be honest but it was just a weird deal.

Hi
I have this issue also using a Surface 3 laptop with AMD drivers.

Updated the windows and also AMD drivers and not been resolved.

Raised with Tiff at customer support also.

Paul Wood