NO signal status after few sec


I have an ELite Turbo Muin trainer with Misuno B+ bluetooth sensor. I tried using zwift through 2 windows computers and 1 android phone with the same results. The reading are dropped after a few seconds. Never managed to exercise more than 20 seconds!!! Not to mention that I have to try 10 times to get readings. The strange thing is that I use “my e-training” app as well and I get the reading there with no problem. I have changed batteries of the sensor, reprograme it, uninstall and reinstall zwift, tried it on 2 different windows computers and 1 android phone. I haven’t found a solution and I am getting so desperate and dissapointed. I expected so much more and I bought this expensive trainer to use with zwift. 


Please help me with a solution,

Kind regards,


If you are using Bluetooth you need to make sure the trainer is not connected to any other app or device before trying to connect it to Zwift. Bluetooth can only connect to one device or app at a time and if you have it connected to “my e-training” app you will have issues.

You also cannot connect a trainer or other devices to Zwift running on a Windows PC using Bluetooth directly, you need to use the Zwift Mobile Link to bridge the signal. The PC and the phone will need to be on the same WiFi network in-order for the bridging to work.