Need help with connecting to Cycleops Power Beam Pro

I have a twelve year old Cycleops Power Beam Pro. It is ANT+ only and uses a Cycleops USB stick. It was working fine until my old laptop died. I just bought a new Alienware X17 and I can not connect. As far as I can tell, Cycleops no longer supports the driver needed for the USB stick. I can easily see on my new laptop that the USB stick is not operating and that no update driver is available. I tried transferring the old driver off the old laptop (it works well enough for that) to the new one and no dice. 32 bit vs. 64 bit? Some other issue?
Is there a work-around? Or do I need a new smart trainer. And one more folks-if I buy a new trainer, how is the Saris H3?

Hi @Mitchell_Tallan, have you tried a new ANT+ dongle, I’m not sure if the old trainer would work with a new ant+ dongle, but worth a shot?

I’ve heard good things about the Saris H3, especially if you like ERG mode for training, apparently it is the best on the market for ERG mode.

Well, it turns out that I was confused about my old trainer and the protocols. ANT+ is still used even current trainers in conjunction with BT. I am pretty sure current trainers no longer need a USB stick. My USB stick, being 12 years old, had some compatibility issues with MS11. My son found a workaround to allow the Alienware to recognize the Cycleops USB stick and to allow my version of MS11 to download the driver and all is good. A new trainer will have to wait.

1 Like