M1 iPad Pro glitching every 5-6 seconds

Every 5 to 6 seconds on my new M1 iPad Pro there is a brief glitch where everything turns dark or shadowy and then returns to normal. I am assuming this is an M1 problem since Zwift was having trouble running on it to begin with but cannot confirm that this is the case.

I have a video but apparently cannot upload videos nor add links to this post.

I kept thinking I was about to be transported to some kind of h*ll dimension, which honestly would have been cool.

Teddy

@Teddy_Svoronos

Is your iPad tethered to an external monitor? If so - how? Wirelessly or wired? Does it clear up if you detach from the external monitor and just use the inbuilt display?

Hi Shuji, no monitor or power cable attached.

Is your video online? If so - please add the URL to your response. I changed a setting to allow you to do that.

1 Like

Great, here’s a link: https://share.icloud.com/photos/0BXz9c4mxsRjnENJ3AR9vI4Ug

After looking frame by frame, it seems that all shadows/lighting get removed for a single frame at a time:

Normal:

Glitch:

@Teddy_Svoronos
Thanks for linking to the video.

@Larry_Linson @Eric_Helfrich_DIRT @Space_Naokki @Alexander_Payne @Yngve_Svendsen @Michelle_Lennox_H_P @Omar_Piza
Thanks all for looping back to confirm the black screen is fixed on the main thread. Would you mind downloading this video and verifying if you also are seeing this flicker of lighting and shadow?

@Teddy_Svoronos
I know this will sound :roll_eyes: but have you tried:

  1. purging the cache for the Zwift app ?
  2. Uninstalling / reinstalling the Zwift app?

Happy to! From what I can tell from this article, deleting the app will also clear the cache, correct?

Yes, true. Please let us know what that does.

REALLY interested in this. just ordered the m1 ipad pro yesterday thinking the issues were solved with 1.13.2. very nervous now since i traded in 4th gen ipad pro which was flawless with zwift. i was expecting better graphics and stable running, and it seems so far i’ll get neither

After a reinstall and restart, it seems like the problem has gone away. Curious to hear if others have experienced it but it looks like it may have just been a caching issue.

2 Likes

I rode for an hour tonight (Champs d’Elysees and a group ride in UCI worlds) and no issues. Graphics were great, everything worked.

1 Like