Issue Accessing Zwift.com on iOs devices [February 2024]

Ok, so this is driving me crazy and its the only website that exhibits this behaviour for me… So basically, trying to load zwift.com or once loaded after 1-2mins, then attempting to login, again taking 1-2mins

Its pitifully slow on Safari under macOS, iPadOS, iOS etc

Interesting, I have not seen that problem. I’m typically looking at my.zwift.com, or event signups, or support pages. Not fast but nothing as bad what you’re talking about, just a few seconds at most.

Are you using an ad blocker? In my case this blocks the cookie confirmation dialog and that causes the site to load incredibly slow…

Hi @Mark_Hulskamp I imagine the importance of accessing Zwift.com on your iOS devices. By any chance, can you please try clearing the cache? To do so, you can follow the steps below:

  1. Launch Safari.
  2. Select History.
  3. Select Clear History at the bottom of this menu.
  4. In the popup, select All History from the drop-down menu.
  5. Select Clear History.

If the Zwift website is still not loading, do not hesitate to contact us at support@zwift.com with a video screen while experiencing this scenario. We will be glad to help you out!

1 Like

Yes, have Adguard Home running at the DNS/Network level, plus 1blocker on systems.

yes, have done those steps… Same issue.

It’s Aguard causing the website to be so terribly slow, came here to hopefully find the answer and saw one of the replies was to turn an adBlocker off, even though it was whitelisted in AdGuard it’s very slow - as soon as I turned off content blockers for the website it rocketed