ISP or CDN issue with latest v1.0.52 files - Z117 at line 601 in Patcher.cpp?

Same issue here too. Tried two different laptops, also tried via mobile phone tethering - no luck. Will have to resort to iPad until resolved.

1 Like

Thn youuuuuu SOSO MUCH STEVE!! But what is the REASOn?

As I understand it, sometimes downloaded files are corrupted or incomplete, so they fail an integrity check, and the patcher cannot complete. Changing the internet connection forces the file(s) to be downloaded fresh, rather than from a cache.

Edit: as explained by @David_Knight4 above.

Replying to my own topic to add to the list… New patch this week had the same error. Again Wi-Fi tethering PC to mobile phone hotspot allowed Zwift to update.

Okay, so we have a workaround, but why is this happening? My home broadband lets multiple PCs, mobiles, games consoles etc. download files from the internet all the time without any problems . . . except for Zwift :frowning:

How do we get this on Zwift’s radar to investigate/resolve?

Have tried again and again, same problem. Have also tried the suggestions Zwift support offers on their website, to no avail

I’m getting the exact same error message. Tried tethering to phone, hasn’t worked. Any things we can try?


Hi Dan,

I have the exact same problem since the November update on November 18th. Been in contact with the support service a number of times, but have not yet been offered a suitable solution. Tried to email the support service again 3 days ago, but they don’t even respond to my email anymore…
I fear that this is a problem that Zwift itself does not know how to deal with.

Look up one post, give that a go. Alternatively tether to your mobile (using 4G) and try the update again.

1 Like

Post above doesn’t work for me. Already tried it. I can trie the phone alternative. Maybe it works. Thanks Dave.

1 Like

I have the problem that after a period of time sometimes 30 minutes sometimes shorter Zwift screen blanks out and windows says programme not responding, has anyone else had this please and how did you fix it

Hey all - thanks for raising your hand in this thread. We’re reinvestigating the lingering z117 errors after the release of the game version 1.19.2 patch that fixed it for many Zwifters, but apparently not all.

Some of you have contacted Support and sent in your launcher log files. We’re investigating those and will update this thread when we have news to report.

I’ve been trying to install zwift on 2 computers that have not had zwift previously and I have been getting the line 602 z117 on each of them.

For those running into the z117 error during the game update process: please refer to this older discussion where a workaround was found. Please try this and report back with findings.

In the meantime, we are investigating the reoccurrence of the z117 error.

1 Like

I managed to update Zwift thanks to both of your tips. But i cannot ride Wattopia, if i chouse wattopia, the program crashes.

But Thanks a lot for the tips!!

Not my tips! Glad you’re sorted with the update problem, but crashing isn’t good. :frowning:

1 Like

I don’t know why Wattopia isnt working, but at least i can use Zwit again after a month. Thanks again :+1:

I have not made any progress with the tips. Zwift support - can you please provide an update?

UPDATE Dec 30: Zwift game app v1.20.1 fixes the z117 error, and just released. Please update your game app at your earliest opportunity.

1 Like

I am still not able to launch Zwift. I keep getting the same Z117 error. I have deleted all folders and still getting the same error. Went through all the suggestions also. I can use it on my Ipad, as a back up, but prefer using my PC to upload custom workouts and do my edits.