Is ZwiftGPS Still Working?

ZwiftGPS stopped working for me a few weeks back. I know there were problems in the past when Zwift updated the way it communicates but it had been working again for a while.

I use the desktop app version and it just brings up the Watopia map and doesn’t update. I tried to website and when I try and sign in with my Zwift ID I get a 400 Bad Request error. I’ve tried opting out and back in to sharing with ZwiftGPS but still can’t sign in.

Anyone else having problems or still using it? Thanks!

I used it on Friday, showed me and a friend’s position fine as we each did a lap of Innsbruckring.

Well, it worked on Friday - let me log in again and showed my position correctly. However, this morning I can’t log in again - 400 Bad Request error. Looks like the login functionality is being a bit temperamental…

I get the 400 Bad Request error as well. 13 Aug 2023, 0650 CDT

I understand that ZwiftGPS is owned by WTRL. You might want to report the problem to them.

Thanks. Martin at WTRL is investigating.

1 Like