Incorrect watts shown

I am having issues with wattage. I am barely touching the pedals and the wattage is showing as 2000w and speed of in excess of 55kph. I have updated the app and made sure my trainer has the latest firmware. My PC has also been updated to the latest software. It is very frustrating as I am now at a loss to fix it

Can anyone help?

This has happened to me too yesterday, we don’t know how to fix. Seems funny after the update on 27th I have this problem, has ran amazing before this

What trainer are you using?

I have an elite novo smart trainer

I think I have found the solution

Check your profile settings. My settings had changed my weight to 725kg for some reason and that was the issue. My actual weight is 72.5kg. It had removed the decimal point. Changed it and all is ok

Mine is still the same. Glad your is fixed. When you were riding on yours and you were going uphill and downhill did you feel any difference? I had no difference and I only usually hit 250-280 watts to hold and mine was hitting 500.
I hope zwift help so I can get back on.

Mine was showing I was riding at about 0.6w per kg but 2000w output. No real difference in resistance though. Hope you get it fixed as it is really frustrating, especially at the moment

It is, fingers crossed they sort it ASAP. Thanks for your help

Have you tried changing settings on your profile in Zwift Companion. That is where I changed mine

Yes looked in both and it’s the same and right. I’ll see what zwift come back and say. I know someone with the same turbo and there is fine. :weary:

Hi Rhys, I have the same issue. Watts way too high. Have you had any luck?

1 Like