Incorrect power outputs

Hello Zwift Hivemind,

I’m having an issue with my KICKR Core, and since I don’t expect to hear back from Wahoo CS over the holiday, I thought I’d pose the problem to you. I have had this trainer for just over a year, and only recently started having this issue (in the past few weeks). It may be an issue with how the trainer communicates with Zwift.

In a nutshell, I appear to be getting incorrect power outputs from my trainer.

Here’s what’s happening. In a free ride, the trainer acts as if I am in workout mode and will not allow me to generate power beyond a certain point. For example, today I did a 45-minute free ride, and here were my observations:

  1. Over the course of my 45-minute workout, output remained consistent at 56-57 watts in a 0% grade, no matter my gearing or cadence. In the first attached image, I was pedaling in the big ring and smallest cog – I really should have been flying.

  2. I did notice (and see) a change in resistance when the grade changed. At 1%, output showed around 70ish watts, and at 2%, 80-90 watts. I could also feel the change in resistance.

  3. I believe that the displayed wattage is nevertheless incorrect – even though it would show 57 watts, the resistance felt more like 160 or so. However, changing gears or cadence up lowered resistance, as if in an ERG workout mode.

  4. At the start of the ride, I tried coming to a complete stop and restarting to see if the system would “reset” itself. It briefly went to a higher wattage but then returned to 57 (see first image). However, when I finished my workout, I tried it again, and this time it seemed to respond. (See second image)

HOWEVER: when executing a programmed workout, for about the first ten minutes the resistance is definitely higher than it should be – when I am warming up at what should be 135 watts, it feels as if I am already approaching 200. After about 10 minutes, though, it will usually reset itself – I can feel a noticeable change, and the power graph even shows a little spike when it happens.

I have followed Wahoo’s instructions to ensure that there is no additional interference, only one BT device connected, unplugged the unit for 30 seconds and plug it back in, spindown, factory spindown.

Has anyone else had a similar problem, or a solution?

Hi @Rich_Strauch, what device do you use to run Zwift? Is it an iOS device, they are having issues with the latest firmware of the kickrs and users have had to roll it back to get it working correctly again.

Hi @Mike_Rowe1, I run it on my Mac (OS Catalina, 10.15.7). How do you roll back the firmware on the Kickr?

Google it

See Wahoo Kickr Core 1.1.1 firmware issues - #5 by Tom_Hagler on downgrading Kickr firmware.

Thanks! I’ll give it a shot today.