HRM shows “No Signal” (Garmin HRM, MacBook Pro using Ant+)

Looking for help! My garmin HRM stopped connecting to zwift (mac book pro w/ ant+ stick)

  • My HRM works w my Bike computer
  • My trainer connects to the computer w no issues
  • occasionally the HRM will show up on pairing screen saying “no signal”, but then will disappear
  • I’ve changed battteries in the HRM and tried multiple ANT+ sticks - doesn’t work
  • I can disconnect the HRM from pairing screen, search for HRM, it comes up … but then after 1-2 seconds I see “no signal”. The only way for HRM to come back (for a second) is to disconnect it and search / reconnect from pairing screen
  • I’ve uninstalled and reinstalled zwift
  • I’m on the latest version of zwift
  • seems like if I “force quit” zwift and restart the app, HRM connects without issue (until the next session when it happens again)

Any ideas? Been zwifting for 3 years, never had any issues… first time!

My garmin dual HRM has been dropping out as well. I’m new to zwift so I can’t tell you if this is a recent thing. Using a tacx neo 2. With pc

Restarting the Computer and turning off all other Bluetooth sometimes produces minimal results… good luck

Hi Matthew,
it seems that you have tried most things but here are a couple of thoughts. . . .

I am guessing that your Garmin HRM is Ant+ only? If however, it is a new Garmin dual HRM, I would ensure that your MacBook bluetooth is switched off whilst connecting initially to ensure that HRM only connects via Ant+.

One other thought is that although the HRM strap may look fine it may have a problem and need to be replaced. (I had this problem last year, strap looked perfect but it was the issue)

Also, I think I have also noticed that static has given me problems now and then, caused by one particular piece of my clothing.

I hope you find the solution.
One last thought, you could try a different USB port if you haven’t already.

Hi

The garmin HRM works perfect with my garmin. I get it wet before riding, so no static related.
Sometimes it connects to zwift and then drops out

Bluetooth is disabled and I’ve tried multiple ant sticks in multiple USB ports

The only thing that reliably works (and usually only for one ride) is to click “force Quit” on zwift, abs restart the software. That’s worked 100% of the time…

This is something software related with zwift I’d I had to guess?

I’ve now tried 2 computers, 2 USB plugs, 2 HRMs (one garmin one wahoo)

Could there be something going on w my zwift account ?