Having issues with not joining the Robo Pacer? [May 2023] [SOLVED 1.42]

unfortunately the issue that avatars can not find the Robopacer on Apple TV 4K 2022 has not yet been solved with the latest update 1.41 !!! the avatar just goes around and then stands still without joining the Robopacer !!! this bug has been in the game since the 1.39 update…

Same issue for me on Win11

I too am having this issue since being forced to update on Friday. Tried to join the B pacer on Watopia Triple Flat loops multiple times from Apple TV and also Macbook pro 13.3.1. My guy just gets dropped on the road at a random spot with no pacer in sight.

So… why is this topic “Solved” ?

Should be merged with this one


Yes, it’s happened to me as well. Both on ATV and PC.
I’m happy James and the team are aware and working on it.

Thank you,

I’m experiencing the same issue. Have just tried to join a pace group 5 times and each time I’ve ended up on my own. Very frustrating.

1 Like

Got in on the next attempt.

right u are Steve The Great !!! after this update 1.41 no way avatars can find Robopacers on Apple TV4K 2022… but the pc version is ok at least on my computer,avatars work normally with Robopacers…the sad here is that Zwift is not coming back on this issue,very bad customer service at the moment !!!

I didn’t have this problem under 1.40 but have about a 50% failure rate joining pace partners with 1.41.

Extremely frustrating. Robopacer functionality completely unusable.

1 Like

When I try to ride with a pace partner it drops me into the world but the pace partner disappears as soon as I get on

This actually seems worse in 1.41 (ios 16.5 / iPad air) compared with 1.40. 5 attempts to join different robopacers today and all launched nowhere near and some launched with me going round in circles. Numbers also seemed very low for all the robopacer groups I’m guessing because of this issue.
There was a ticket in known issues for 1.39 for this issue which support just closed saying there will be a fix in the next version - not really acceptable. Please fix this as a high prioity - a large part of the attraction of Zwift is easily being able to ride with others.


I posted earlier on this topic. Many issues with Pace Partners including the game not being to actually find the pace partner you select. It was promised to be fixed with the recent game update - but it’s not - it’s actually worse. Took me 4 times to connect to a pace partner this morning. Same issue with many of my friends. @James_Zwift what you say?

1 Like

Today I had to log on to a Robo pacer ride multiple times (5 I think) to finally find a Robo pacer. When I did the Robo pacer was sitting sideways in the roadway flickering on and off. Anyone know what this is about?

Also today, once I finally logged on and could join a Robo pacer ride, I saw multiple occasions where someone else’s HoloReplay was in my display. Anyone know what this is about? I’m going to try and upload images and videos

I captured. Hopefully I can figure out how.

Couldn’t post video of the blinking Robo pacer, but here’s a still shot of it sitting sideways in the roadway.

1 Like

See this

1 Like

Well thanks! That explains the extra HoloReplay seen on my ride. Now if we can only figure out the missing, and then sideways blinking, Robo pacer

Still happening’ please fix