Group ride with pace partner bug

Dear Zwifters,

since the last 2 updates, there seems to be a bug when riding with pace partner. It’s reproducible:

  1. Select to ride with PacePartner, e.g. C.Cadence. Upon clicking on “Ride with C.Cadence”, the world map loads but you are not joined to the group. Instead, you are placed in one of the normal starting slots of the map.

  2. So you go back to the menu and trashcan the activity. You reselect the pace partner and click on “Ride with C.Cadence”. This time, you’re placed in the group ride, but your avatar refuses to spin his legs, although you are pedaling like normal. Power is beeing shown in the HUD and it looks like that youre avatar is just coasting with a lot of Watts between other riders without any kind of movement (no draft indicator etc).

2’nd step repeats all over again.

Only way to resolve this is to close Zwift and reopen it, then it works as it should. Haven’t been able to find any kind of trigger that causes this behavior.

Hi @Mike_Medwed

What system are you using? This is not the experience that I have with pace partners.

HI, Zwift is installed on a Windows 10 Laptop with all updates installed. It used to work without issues before the last two Zwift updates, that’s when I first noticed it.

I last rode with a pace partner on Dec. 30th, and it worked fine. I don’t see any other reports of this behavior on the forums so it could be isolated to your system somehow?

It has done it to me twice

I just tested this and joined the B and C bot without issue on windows 10.

1 Like

I just launched Zwift and join C. Cadence and it behaved exactly as I would expect - joined in the middle of the pack with pedal assist on for 5 seconds.

Running Windows 10 x64.

It sometimes takes a few seconds to drop you with the group, during which it may look like it hasn’t worked. Are you waiting long enough? I wonder if interrupting the intended joining behaviour is breaking it the subsequent times. Would explain why it’s fine upon reloading the game, because the process has been reset.

Hi Mike,

I’ve had different experiences running Zwift on different Windows 10 laptops. One laptop, with a higher spec, loads much more quickly and seems more reliable on Zwift. The other (lower spec machine) takes longer and seems to say “not responding” more often, and this difference feels to be exaggerated when trying to ride in certain worlds. So two questions I have are:

  • What are the specs of your machine - e.g. processor? Dave will be able to tell you if how close your machine is to being “optimal”.
  • Have you had this issue joining a pace partner in Watopia, Makuri Islands, or both?
  • If you’ve had the problem in one of those worlds, how does it differ when you try it in the other world?

It is intermittent…Its not an every time kind of thing…it was in watopia and it happened in IOS and on a pc both have never had this isssue until last update.

Just to add for context, I’ve also had it twice since PP introduction, not recently and I’ve also seen the odd rare post in the forums over that time (maybe 2/3 posts?). Hasnt bothered me tbh given how quickly I can relaunch a ride.

When it occurred I felt I did something wrong, along the lines Dave mentioned above, though never been able to replicate it.

Hi Dave, I’m aware that it does take a few secs to get placed in the group. It usually takes around 2-5sec. But in this case, when the behaviour occurs then you won’t be placed in the group even after 30sec onwards. The issue occured twice so far when joining pacepartner in Watopia. Didn’t try it in the other world, tbh.

@Paul_Rayner: My Laptop is as follows:

  • i7-11800H
  • 16 GB Ram
  • RTX 3060mobile
  • PCIE4 SSD

I also did monitor CPU Temp and overall sensors, there was no Throttleling or overheating. I ride most of the group rides on weekend, starting at around 7-8 a.m. berlin time. So the group isn’t that big and most of Watopian riders didn’t woke up yet.

2 Likes

Today I noticed what might cause the issue.

In the homescreen, you select to ride with a pace partner but you don’t click on the orange “Ride with C.Cadence”. Instead, you click somewhere else, like select route or on select workout. After you made your choice, you go back. Then the Ride with button is still orange highlighted, but the pace partner got deselected, not highlighted in orange anymore.

When you then click on the “Ride with” Button not carefully reading what it states, then you are being placed in the normal starting lots not, with the pace partner.

When you notice it and select the pace partner once again, then it works as it should and you get placed in the group like normal.

1 Like

This is also happening to me - I’m using an iPad Air 4, the problems started with the recent and continued with the bug-fix update 1.25.1. I ride a couple of times a week with the Pace Partners, and last week when they were going round the volcano it seemed you could work around the problem by heading out that way after Zwift had dropped you into the default Watopia starting position - after 30-60 seconds you were transported into the group. However, tonight, I tried 3 times to join, both in Watopia and Makouri Islands, and even after 2 minutes nothing happened; in the end I just ended up doing a free ride.

I have the same problem with joining a pace partner and just being dumped on my own at the start of the route. Tried on 2 different Android devices and versions.

When this happens, do you exit the screen “immediately”.

I use ATV and have noticed recently that I’m not always dropped straight into the group. I just start riding and, hey presto, moments later I’ve joined the PP.

1 Like

Interesting. I’ll try that next time.

Just had this problem on ATV on 1.25.2. First time it just dropped me in downtown. Second time it worked ok.

I thought I had seen a post from James saying this should be fixed now, but I can’t find it.

Edit - found it - Pace Partner failed to appear - #4 by JamesBailey