Game Update v1.48 [September 2023]

The release notes say it now requires a press and hold to a U-turn.

Everything worked as expected with mine on the ride yesterday evening (on 1.48). A press and hold of the right minus button worked fine.

You would have to be on Bluetooth connection for this to work, as from if I remember correctly, these button commands only work over Bluetooth

Yep, as @Jon_Wakefield said, make sure you’re connected to your Kickr Bike via Bluetooth for this to work and not ANT+.

Bluetooth seems to be the thing. Thank you!

1 Like

A post was merged into an existing topic: Video Screenshots - Windows Release [July 2023]

4 posts were merged into an existing topic: Native Apple silicon Support for M1 and M2 Macs Enabled [1.47] [September 2023]

youtu .be/ pXRVGk3KVVE

Zwift Play Controller connectivity is still not working reliably.

Zwift Game Client: 1.48.0
Zwift Launcher: 1.1.10
Zwift Play Controllers: 1.2.0

I’m glad it’s not just me with the play controllers connectivity. Mine won’t stay connected direct through bluetooth despite working fine when paired through the companion app, and despite working fine when I first got them (Aug update broke them I think, although I was on holiday so I can’t tell exactly when it happened). I’ll see if this makes a difference when I join tonight.

Spoke to soon, the next couple of ride the left controller now disconnects pinning me to the left side of the road until I can get a reconnect. Happens 3-5 times in an hour long ride.

My right Zwift Play continues to have lots of dropouts, but now it reconnects much better and shows steering as “On” and keeps the ride-on bomb circle working!

I was (10 minutes ago) on Makuri 40 (free training) big bug on the course… in fact I was always out of step with what was displayed. When I was on the flat 0% I was on a resistance at 5% which corresponded to the bump that I was soon going to climb… when I was on the bump I was already at -2% that’s to say the descent… imagine on a race :partying_face: :clown_face:

1 Like

I can get my Zwift Play to connect via the companion app now, but the game client always seems to drop my wirelessly network-discovered Kickr V6 power source / controllable / cadence connections WHEN I switch over to “pair with phone” as opposed to “bluetooth”… then it takes some switching back and forth between the two options to finally get the “pair with phone” menu to retain the network-connected power/controllable/cadence connections. I can’t figure out how I’m supposed to get my HRM to work in this scenario without a separate ANT+ dongle.

Can’t you guys just make Zwift Play controllers work over USB? Fun fact - our front tires don’t spin while we’re on trainers. I’d take a reliable cable solution any day over this BLE bologna.

No improvement from this update for the Play controllers connectivity. Still won’t stay connecting for more than a few seconds (TP-LINK UB4A if it helps)

iOS and Apple TV users please note a v 1.48.2 patch has released to the App Store.


My kickrbike still seems to be having dropouts after extended periods of riding (90+ minutes).

Started doing it after v1.44
Never had a single drop since I got the thing in February 2022… until the release of Zwift v1.44

Mentioned it along with another user on the 1.46 thread.
Nothing new to report other than the fact it’s not a one computer specific issue; as it appears to be happening on both of my computers (I suspected it was one, and let it slide thinking it was specific to this one computer; however that is not the case).

Meanwhile I can literally go onto Zwiftalizer, pull an old log I have on a computer I don’t use as much which has logs from back in June and they are flawless… they show like extremely few % RXFails but 0 searches for several hour long rides.

Then I can chuck in my recent logs in and it’s much more fails and even goes into searches.
Despite never actually changing anything or moving things around.

At one point back in August I even tried an extension on my ANT+ dongle, and put it literally within 1ft of the antenna on the kickrbike and the thing was STILL going into search mode for the signal.

I struggle to believe this is something on my end. Especially after it was so flawless for over an entire year.

Are you using the same ANT+ dongle on both computers? If so, it’s possible it’s the dongle starting to fail.

I can’t say if this is a bug (could be!) but when there is a possibility of wireless interference the scope of what may have changed includes everything else in the environment, not just the equipment you’re trying to use. Plus the operating system is generally not static. It’s rarely possible to confidently say that nothing changed.

1 Like

Have you tried running a Bluetooth dongle on an extention lead ?
My Bluetooth dongle is with 0.5m (18in in freedom units) from my 4yr old Kickr Core on a 4m usb lead (12ft).

I’ve always found that Bluetooth reacts quicker then ANT+ too, might help your racing performance :slight_smile:

It’s just so much that I’m out of control of on the software side of things; but it just seems odd I don’t seem to be the only person with a kickrbike recently experiencing this issue.

I’ve tried bluetooth before once or twice, it’s only ever given me bigger issues.
Also, turns out (and I cannot produce enough hate for this). My mini desktop with an ASRock board with bluetooth built in; not only can it not see the kickrbike; turns out… thanks to Windows not being able to handle two unique bluetooth dongles/antenna systems… I literally can’t even use bluetooth on this other computer of mine; because I can’t disable the bluetooth in the bios.
Drives me insane.
So for any of you other common-ers on here ever runs into someone having issues with bluetooth issues specifically on a Windows machine; definitely try to remember to ask them if their computer came with bluetooth; because for some stupid reason, not all motherboards can disable bluetooth… and there’s nothing quite like putting bluetooth on a motherboard just for it to sit inside a faraday cage of a computer case :person_facepalming:

I’ve just never had issues with ANT+ until August… just find it weird.

If it’s not that widespread then I guess I get to go back to fiddling with things; just kind of difficult to test as it only happens on rides that end up being closer to 2 or more hours

you should be able to disable one of them in device manager

1 Like