Game Update 1.51 [October 2023]

Been like that for some time.

The, what I can only assume is cylindrical, 2D graphical cloud layer seems to be clipping through the 3D mesh of the surrounding mountains.

SA’s bug is a wild one.
I’ve never once had issues running many multiple rides without having to restart Zwift before; and definitely nothing like that.

Side note; the asset streaming while loading into Watopia though is a bit wild now; almost a full minute for things to be popping in. A bit on the extreme side when some of us have beasts of computers.
I presume this was just a choice to help lower end machines?


This was really apparent in the desert on my first 1.51 ride. Get in, think “huh, major update here, lots of nice new textures, but I guess they decided to take out all the foliage?” And about a minute into the ride it all popped into existence. The dead leaves on the new road also just popped into existence right in front of me when they first appeared. (side suggestion to ZHQ, just nix the dead leaves, they don’t add any ambiance but do seem to affect performance)

i fixed it brother (zwift and fps monitor do not like eachother. i don’t think it will affect anyone in normal use. if you are going through something similar, it’s possible an overlay app or something is interfering with zwift. disabling it might help) but that solution would not work well for me. for example , i like to line two or three events up and do them in a row. having to leave the game before each one and possibly miss the start of an event would get infuriating fast. anyway, problem solved, other than the fact that the game is running equally as bad on my gaming + editing pc as it is on my £300 zwift pc. looks pretty at least

I’m consistently seeing the issue where the “second power up” animation does not show up anymore. Has anyone else noticed this?

Not a big issue but I think it’s a minor regression.

It’s the animation you would see if you go through an arch already holding a power-up.

Here’s a screenshot before the arch:

Just after the arch you should see the animation cycling through the various power ups at the spot indicated by the red circle, but there is none:

Then the second power up just pops in without an animation a few seconds later:

Again, this is on iPad.


will keep an eye out. some minor things i noticed were the black squares, though i think zwift are aware of that one, increased loading times and textures taking a while to load properly, and also if you flick through the side bar when fan viewing people the game eventually stops loading in people’s usernames and their equipment. could see that one causing TTT directors some grief

just want to say that the game does look nice, it’s cool, i do appreciate the update. i like my frames though

1 Like

On what device and spec? New update is very heavy in CPU usage for Watopia so perhaps you are hitting the limit….?! How does Makuri load?

Also try turning off video screenshots if you have that option and it is enabled; that will reduce system load and may get you back in the game for now.

Just another minor bug:

Bright colours bleed through from one side of the screen to the edge of the other. Will try to get a screenshot to show it; most noticeable in the volcano, bright yellow lava from one side bleeds through and shows in the edge of the opposite side.

An older issue that has been raised I believe but seems back/worse on 1.51 and now left-right as well as top to bottom.

Win 10 PC - i7 13700K, 3060Ti

Thanks for reporting this - do you recall the approximate date and time of the crashes? That will help us investigate logs on our end.

If you’d like, you can upload a video recording to YouTube if you have an account there (you can set it to unlisted/private) and share a link to it - it would be helpful to see more details on this one.

Great catch, thank you! Really appreciate the photos. I just reproduced this on my end as well (on Mac) - I’ll ask the team to look into it.


With 1.51.0 on macOS, Leaderboard HoloReplay setting (Hide) was reset to Show.

Other HoloReplay settings (all off) were unchanged.

no grass, no rock nothing. 4k resolution setting. before i use 1080p but afrter 1.51 i switch to biger resolution why image quality is bad on 1080p

This happened to me on PC today.


This has been happening for a while, but I think it’s worse after the graphics update. Visible here. Just the sky bleeding through. Used to mostly take Tron bikes to do it (plus some other bright objects)

Having the same problem. My HR strap is no longer cnnected (companion via atv). iPhone says in the settings it’s connected. Please fix that zwift. Seems an ATV issue with 1.51

Hello, When will there be updates for mountain biking? Specific equipment, wheel… Mountain biking requires more effort but fewer kilometers but you have the same rewards as a road bike. It would be nice to have different rewards. Thx

Can‘t find a way to edit existing custom workouts. I‘m on iPad. Any idea?

1 Like

Thanks for finally getting rid of the annoying tunnel vision’s gradient effect. Now my OLED display looks clean from side to side :wink:

Are you referring to the workout pain effect?

You can enable/disable that in settings.

No, it is not the workout pain effect. It is a display/graphic effect that makes the side borders of the display look like with vertical banding to give it a more 3D “kinda” visual effect.