Game Update 1.25 - May 12, 2022

I know next to nothing about computers or apps and how they do (or should) work, but is it possible that the CPU load near intersections is not due specifically to the pop-up option dialogue, but to the fact that you have an option to go two (or more) different directions so the game has to load the assets (or whatever) for ALL options? Then, once you actually pass the point where you can make the choice (dialogue disappears) the game can discard the assets for the non-chosen option. Pure speculation on this.

3 Likes

Yeah I mean what you’re referring to still makes complete sense, and could absolutely be on the right track potentially.

For the time being though it’s pure speculation. And regardless we have evidence something is up, and hasn’t been happening before (that I ever have seen at least)

As a follow up follow up; looks like my support ticket pushed through and “has been escalated,” sadly to… basic tasks.

SO, I guess ZHQ doesn’t look at these threads enough, so I think I’d recommend anyone else seeing the blurry workout effect that’s come in 1.25 and the massive frame drops… also put in support tickets.

We need an actual response from ZHQ; we still haven’t had any official statement on this yet, and it certainly wasn’t an issue prior to this patch.
(and is still happening after that hotfix)

One could argue that before 1.25 it worked and there wasn’t a difference between free riding and doing a workout. Or at least it wasn’t that noticeable. So obviously something MUST have been changed. Definitely not for the better.

Btw, this is my pain effect:

This time the fps dropped hard shortly after the effect was noticable on the screen.

This went from not working after the initial release, to working last night, to now not working again.

Hi,

Is anyone else having issues when doing a custom workout that the first segment (Star) you don’t get it anymore… I have tried on my laptop and Ipad and both times it has been missing. I have tried to search and see if I could answer but have had no luck!

@Sharon_Rae See here, there’s a thread about it:

Anything of significance in the 1.25.1 update on May 18th?

See a few posts up - Game Update 1.25 - May 12, 2022 - #175

1 Like

Sterzo Error with 1.25.1

Checked firmware and changed batteries just in case, but no go

Hello, was the “workout pain effect” changed too? Earlier it looked more like horizontal stripes but we could see through just fine. Now the screen gets more and more blurry and we cannot see much till the interval ends.

A few people have reported this, yeah. Seems like a bug rather than an intended change. May or may not be related to big frame rate drops at the same time. :confused:

1.25.1 update crashed today, 5/22. Windows 10 laptop. “Update Failed during patching. Error Code: Z117 at line 602 in Patcher.cpp. Please contact Zwift support. Would you like to try to launch Zwift anyway?” (I tired, would not launch, I tried to reinstall, same error).

I had this error when I first tried to update zwift this month but I rebooted my pc, it installed the update again and everything was fine.

There’s a bug with automatic activity naming recently:
Last week I rode a workout on Castle To Castle, and the activity got named Zwift - The Gorby on Triple Flat Loops in Makuri Islands. (TFL isn’t in Makuri Islands…)
Last night I rode a workout on Triple Flat Loops, and the activity got named Zwift - Debbie’s Killer Minutes in Watopia. Why doesn’t it match the route into the activity name?

Another tiny inconsistency; sometimes the navigation options at the bottom of the screen are block caps (CASTLE PARK) and sometimes not (Downtown). Gets my OCD twitching!

2 Likes

With this update I have a problem with my ATV (latest model). In many areas of Neokyo the frame rate drops massively. This behavior shows up even when there are few to no other riders on the track.

1 Like

It worked for me on Thursday 19th May on PC with 1.25.1…didn’t use zwift since.

Is this when doing a workout, perchance?

Yeah, for some reason it worked the day after the errors. Haven’t tried again since though.

Yes, especially along the route where these colorful trucks are parked.

Thanks very much, I did try that several times. Moving to a different wifi network seemed to be what solved the problem. Not sure why.

Zwift sent me the following email. I did not have to do the following but will keep in mind in future. Maybe will help someone else with this issue.

Thanks for reaching out to us! My name is Emilia and I’m a Support Specialist at Zwift. I’m sorry for your problem with Zwift, but I’m happy to assist you.

The z117 error indicates that Zwift is unable to create or write to your Downloads folder.

For more info on why this might be happening, check out our article:
(forum post won’t let me include link)

Once you’ve gone through that checklist, let us know if they apply or not, and we’ll go from there.

(Link says this)

Error Code: z117

Issue Summary

This error indicates Zwift is having difficulty writing in the Documents folder on your computer. Here’s some of the reasons this may happen:

  • You are not an Admin on your machine.
  • Another program on your computer is interfering with Zwift.
  • You have less than 4GB of free space on your hard drive.

Workaround

These are a couple possible workarounds:

  • Right-click on the ZwiftInstaller file and choose ‘Run as Admin…’ even if you already have Admin access on your computer.
  • If you have an antivirus program installed, make sure it’s not preventing Zwift from writing to your account folder.
  • If you have a sync program (e.g. Dropbox, Microsoft OneDrive) installed, make sure it’s not syncing your Documents folder.
  • Make sure your default Documents folder is accessible.

If the Documents folder is saved to a disconnected network drive, it may not be accessible.

  • If the workarounds above don’t work, try deleting the Zwift folder under Documents , and then re-launching Zwift.

For more info, check out this link on our forums.