Game Update 1.17 - September 15th, 2021

Too many jokes

8 Likes

Noticed this on a London ride today as well. I just thought it was me that the overtaking seemed extreme.

3 Likes

Yes the draft is now completely broken in certain situations. I’ve raced Watopia a few times and NYC since the update and they were normal enough. London was a total mess. Constant zig zagging. Most users in our group confirmed.

4 Likes

Ever since this update, now my Bluetooth won’t engage. Im using a KICKR with AppleTV. Zwift indicates I’m connected but when I join a group ride I feel zero resistance and no draft effect. Kinda takes the fun out of Zwift :woman_shrugging::woozy_face:

I am continuing to have BLE issues with this update. Setup is:

Wahoo Kickr 2018 w/Climb
Apple TV 4K
Latest firmwares installed on everything

In general everything works fine but in several specific places on Watopia the BLE just disconnects all devices and won’t reconnect. Am experiencing this at:

  1. Base of radio tower climb (when it starts going up)
  2. Base of Volcano KOM a few hundred yards past the KOM marker
  3. Base of the Alpe KOM, again just after the KOM marker

The drop out is consistent in that it happens every time am in that spot. Rest of Watopia and other maps are fine.

Figured out today that I can get through these areas by connecting via the app. But have to connect the controller via the app as well, and then it doesn’t change resistance at all.

Have not experienced this during an event. Only when free riding.

Yep, I have seen the same problems that others are reporting. This is on the iPad version.

It seems like the Progress Bar has disappeared. I have tried the London Classique and the Watopia Sand and Sequoias routes and neither had the progress bar.

It also looks like the swinging wide drafting bug introduced in the July release on left handed roads (Makuri, London and Harrogate) is back. I only did a brief test on London and it certainly seems like this is the exact issue we had back then when avatars would swing excessivily wide when passing other riders.

It seems like something has really gone wrong server side (as these changes have happened after the Sept update) and they’ve reverted a couple of versions.

2 Likes

Why did the progress bar disappear??? Windows 10 :frowning:

The 9/15 update caused the route name, progress bar and remaining distance to not show up on free rides. Is anyone else experiencing this? Running Windows 10.

Yeah same is happening to me, there have been a lot of reports of this.

Has anyone experienced the events not showing, no riders on the course after the update? This has been my problem ever since. Although all the upgrades in the garages are there the rest of what was written up is not. I can’t join all the events I’ve signed up for. Thanks if anyone can shed light and help.

Zwift and ATV works perfectly since I started to hard-stop the app after each ride; double click monitor button on Apple remote, swipe to kill Zwift app.
No more ERG issues since then.

Hi @Rafael_Aquino, welcome to the forums. This sounds like a network connection issue, if Zwift can’t access the internet then no other riders will populate in the world. Check your connection, restart your wifi routers, etc… that might clear it up.

I just did a few minutes freeriding in London and it looked like the new dynamics was in operation. Very smooth and easy to pass.

New new, or old new? :wink:

3 Likes

Really? it was an absolute disaster when I tried it yesterday.

It looked to me just like that video on zwiftinsider recently. It was quite striking. None of the swinging around during overtaking that you often see. Less sticky draft. But it was just a short ride.

Update 1.17.1 - September 20th

  • Fixed an issue that would cause native bluetooth pairing to fail on some Windows 10 devices.

Hi Craig! Good feedback, Brother. It looks like deleting and reinstalling the Zwift app on the Apple TV was the thing that fixed my problem of no resistance. I teach physics for a living and am fairly embarrassed that I didn’t run a controlled experiment by deleting and reinstalling one app at a time. You deserve a pat on the back and I deserve a kick in the pants.

And you are also right about your second point. Zwift needs to show its customers some courtesy in their forums by posting a brief comment that they are aware of the issue and are working on a fix. Are you listening Zwift? We are not asking for your first born male or female child. Just a little respect for customer’s time and energy as they try to navigate your broken updates.

3 Likes

Yes. The progress bar, route name, and distance to go worked for the first day and that was it. On my ride yesterday I sent a message out to the Zwift world I was riding and asked if others were missing these metrics. A couple responded and said the metrics were missing for them too. I am running Zwift with the Companion App and Apple TV. So the problem is on Apple’s tvOS and iOS too.

Same for me. I had to uninstall, reinstall, and reupdate to get it to connect to my laptop’s bluetooth. The trouble is, the progress bar is missing from all routes, and now after I save, it justs immediately exists the program. It’s like the update actually reverted back to a previous iteration of the application.