ERG mode doesnt work with Neo and apple tv

resistance

(frank Andreasen.VTri[DBR](D)) #7

i did find and read that thread and actually thought that was my problem because i had 2 loss off ERG where i stopped and ran inside to get something and my HRM was offcourse out of range but the last 2 times nothing went out of range and nothing was idling
also i noticed last night that if i stopped pedaling it didnt say ERG disabled as it allways did before but still felt like ERG was trying to controll a little but couldnt do it anyway so i had to hit the wattage targets myself


(Lin Alan) #8

Just so you know, I too am on Neo and Apple TV 4K.

Curious, do you shutdown Zwift completely between sessions? I always completely shutdown Zwift and manually put the Apple TV in sleep mode. I cannot be sure, but not completely shutting down Zwift could be an issue especially if the Apple TV goes into sleep mode. Who knows what state Zwift ends up in after going into and out of sleep mode. :grin:

Also, there were some complaints of the Apple TV not reconnecting to wireless after coming out of sleep mode, but I have never had that problem. Perhaps, it was with an earlier version of Zwift or TV OS.

It may not fix anything, but a power cycle of your Apple TV sure won’t cause any more problems. After updating apps, the TV OS, etc., a power cycle is probably a good idea.


(frank Andreasen.VTri[DBR](D)) #9

yep i force shutdown zwift after every use and on top off that i unplug all devices including apple tv after every use to save power and because all is placed in paincave in my garage

i have created a zwift support ticket and awaits an answer


(Clive King [KRT]) #10

workaround I’ve found for this is not to go from freeride/other events into group workouts needing ERG. Exit Zwift after warmup (freeride), kill App (swipe up), restart Zwift and then log back in and join event immediately without turning pedals. ERG then works fine.


(frank Andreasen.VTri[DBR](D)) #11

gotta try that even though it is a stupid workaround and just bound to fail when one have to do that just before an event :frowning:
and everything has been working perfect for the last year so they have broken something somewhere


(Vincent W.) #12

Hey @frank_Andreasen I see you sent in a support conversation, and thank you for the details! Although this seems similar to the bug we caught here (BLE Resistance Issues (Mainly on iOS Devices)) can you see what happens if you ride without your heart rate monitor paired? I know it may not be ideal but it can give us some extra information.


(frank Andreasen.VTri[DBR](D)) #13

i can try that on next weeks workout event
just did our zone 2 social ride tonight and went for a warmup before and let zwift take me to startline and resistance was there just fine in Sim mode
it seems to me like it is only in ERG mode in workouts the issue shows up


(Vincent W.) #14

Alright sounds good! I’m also curious if your issue will be fixed in the newest update with the BLE resistance fix.


(Clive King [KRT]) #15

@Vincent I also watch to see if this long standing issue (that I also previously raised a ticket for - you blamed tacx, tacx blamed you!), gets fixed with BLE issue.


(frank Andreasen.VTri[DBR](D)) #16

when will next update be ready ??


(Vincent W.) #17

Hey @frank_Andreasen the newest updates are out now. Can you update if you’re still having trouble with ERG mode? @Clive_King @_Fer_Fox_Sakes @Jimmy_Soh @NSC


(Sergii Salkov) #18

Hey Vincent,

I’ve updated in the morning before the training session and the ERG-mode failed twice during the group ride. It has been working properly 10 min warmup and 5 min interval, however was “temporarily disabled” on 30 sec on 30 sec off and the resistance locked so it was really hard to keep pedaling. I’ve quit Zwift and rebooted the trainer, reconnected to the ride and had the same sequence, however one of the short interval sessions gone well and on the second one ERG-mode switched off again.
I’ve never had such issue before. I’m using 2018 macbook pro and BLE connection. Neo firmware is the latest. Last season I’ve connected via Ant and everything worked fine so I’m going to try this configuration and also remove the battery from the power meter so it won’t try to connect to Zwift as well. I don’t know if wireless headphones could possibly affect the connection.


(( C)raig) #19

Nope, not fixed, I had issue this morning, again after 30 mins into group workout.

I did solo workout yesterday, worked fine after update.

Group workout today, failed after 30mins. Is there is a difference in ERG solo vs group workout?

My setup, all latest firmware, software etc.

KICKR 2017
iPhone 6s IOS 12.1 (Zwift Companion latest, using Zwift Link to connect BLE devices to AppleTV)
AppleTV

The AppleTV seemed to have lost all BLE connections, but Companion App was still working, I was still receiving messages from other Zwifters on workout. I have Zwift ticket open, maybe someone can take a look at the log from the ride today?

Didn’t see this issue last winter, same hardware config, something with recent Zwift updates has broken.


(Clive King [KRT]) #20

within a workout ERG will auto switch off it you cannot maintain the Watts for given interval. That is normal behaviour. Yes they can be hard and if you drop your cadence will feel impossible. Keep the cadence up to complete the 30s interval and erg will not drop. This is different to the issue we are seeing whereby ERG is lost completely in a group workout (does not start enabled). I’ve yet to test this going from freeride then to ‘group’ workout to see if it still exists.


(Sergii Salkov) #21

I could easily maintain the cadence and the power for given session. ERG mode just didn’t start on random (short) interval block notifying me that it’s temporarily disabled and didn’t restarted after notification on consistent pedaling or something like that. In addition to that, when I was trying to hit the target power the resistance stuck on that level and I could barely spin that “gear” and it persisted even when I quit Zwift.
I did free ride - group ride sequence on Tuesday and everything worked fine for the whole workout with the same configuration. I’ll do it tomorrow either to investigate the problem more.


(Clive King [KRT]) #22

Understood - That’s clearly another problem. Not experienced that myself.


( Fer Fox Sakes [DIRT]) #23

Update fixed the issue with my rig. Just made it through a 60 minute workout with no glitches. Riding on a CycleOps Hammer.


(Sergii Salkov) #24

Using Ant+ dongle instead of BLE solved the problem for me. Did a 100 km ride today and interval session with ERG-mode yesterday - everything went flawlessly.


(Clive King [KRT]) #25

This weekend I went from a Freeride straight into a Group Workout (with ERG) without restarting Zwift and I did not have any ERG issues. Not sure if this is a one off. Fingers crossed :crossed_fingers:


(Vincent W.) #26

Great to hear Clive! @Sergi have you gotten a chance to test with BLE any time recently?