Crash with Intel NUC 12 Pro / Intel Iris Xe Graphics

I have recently purchased a Intel NUC 12 Pro with Intel Iris Xe Graphics.

Because of all the Zwift problems with Intel Graphics 10th gen and 11th gen I have waited for the new 12th Gen.

But it seems the problem with the crashing/freezing (as described in different topics) still exists with the most recent version of the GPU.

I dont think it is possible to use the old graphic drivers with Windows 11 and this Version of GPU.

Will this issue fixed any time, or it is it necessary that I use my old Zwift PC for another year?

Give this a go.

1 Like

Thank you. Will give it a try and let you know…

Hey Dave, I just stumbled on this after 6 months of crashing insanity. Does the OBS thing actually help with freeze/crashing with UHD Integrated graphics or just help cure the flickering avatar?

It fixed the flickering stuff, but that’s been mostly resolved now anyway. I’ve been told by a few people that it can also resolve the crashing on 10th/11th/12th gen iGPUs, so give it a go and see how you get on. Remember that it needs to be running, not just installed. If the icon is in the system tray, that’s all good. Doesn’t have to be actually doing anything of course.

Thanks Dave, I used OBS last night for the first time on a Maria bot ride and got 30 miles in and there was a different vibe with the ride. Normally my avatar does a good amount of surging forward and back but it wasn’t doing that, and overall it was very smooth and seemed better. so i’m cautiously optimistic (i’ve been before though).

Are there any other tips or tricks I should try as well for the intermittent crashing/freezing issue? Dell XPS 8940, Windows 11, UHD 750 Graphics only (willing to upgrade graphics if its known to help).

I would suggest maxing out the iGPU memory allocation in BIOS if you can, and also tweak the Intel driver settings like this:

  1. With Zwift closed, right-click on the desktop and open the Intel graphics properties.
  2. Go to 3D, then application settings*.
  3. In the applications selection box, hit Browse and find Zwiftapp.exe (it’s in C:\Program Files (x86)\Zwift) to add it for for custom 3D settings.
    *3a. If you don’t see application settings, change General Settings at the right to Custom Settings.
  4. Toggle vertical sync to use the Driver Settings.
  5. Hit apply, then yes to keep the change.

Note that these steps are based on Windows 10, so they may be slightly different for you. Changing this setting won’t improve performance, but allows the frame rate to be as high as possible without constant tearing, making the game feel much less choppy.

I have also tried to mess around with the Game Setting in Windows 11. But in the end the in my case the performance is not the limiting factor.

The Game is freezing randomly after 5-25minutes. It is absolutely not useable.

I have no understanding why this issue is still not adressed by Zwift.

However I switched back to my really old CAD Nvidia Quadro… This is loud and inefficient, but rockstable…

Are you running OBS as suggested?