Connexion Bluetooth tapis BH i Boxster plus [March 2024] [1.61]

@Simon_VARLET @Lubo_Dekan_ZLDR @Francisco_Martinez3 @Xes_FerGo @Anders_Hjalmar_Tri

Thanks all for reporting this issue with your BH treadmill. We’re working on it, and targeting a fix in the next game update.

3 Likes

my Bh BOXSTER PLUS is just like that since last week,zwiit detects my treadmill as a heart rate sensor

Hi all, this issue should be fixed in Zwift game update version 1.63 which is starting to roll out this week. Please let us know if you continue to experience this issue after updating to version 1.63.

1 Like

After the update, zwift detects my Bh boxster plus, but there is still a problem that when increasing the speed zwift does not detect this and it always stays at 0kmh

Thanks for reporting, and just to confirm, were you using this same treadmill in a previous update and it was working as expected at that time?

Also, if you haven’t already, please try unplugging the treadmill and plugging it back in (to force a restart) just to help rule out anything going on with the treadmill itself.

Hello Alfredo i have also bh treadmill plus can you tell me how to acctivate de bluethoot on my treadmill . Im new here when i connect with zwift after the latest update , zwift dont find anthing . You have to push a button are just play start on the treadmill ? To connect bluethoot ?

Hello Alfredo i have also bh treadmill plus can you tell me how to acctivate de bluethoot on my treadmill . Im new here when i connect with zwift after the latest update , zwift dont find anthing . You have to push a button are just play start on the treadmill ? To connect bluethoot ?


Hello Santiago, no need to push any button , Zwift finds my Treadmill
This month that’s when Zwift finds my treadmill on heart rate sensor from Zwift , that’s the issue
Now after I updated from AppStore , Zwift finds my Treadmill in run sensor and he sensor too

When Zwift corrects all , our treadmill will can be found only as a run sensor like it as been for 2 years

Allready done what you adviced me and still the same problem
For the last 2 years my Treadmill works just as intended
Now Zwift finds my Treadmill as a run sensor and a HR sensor too
Before the issue the Zwift only finds my Treadmill as a run sensor

image0.jpeg

1 Like

The same thing happens to me as to Alfredo. Before the update it did not detect the treadmill bh, but now it detects it and it stays at 0 km/h

HI @Xes_FerGo, welcome to Forums. This is Juan from Zwift. Thanks for using this space to share your concern.

I took the initiative to check your game logs, and based on this, I noticed that you are running Zwift in the previous game version. I’d like to suggest you update it by clicking here. Let’s give it a try.

If the issue persists, do not hesitate to contact our support team. to provide one-on-one assistance.

Hello! I have installed the last update since April 17. Before, the treadmill did not detect the bh treadmill. After the update it detects it, but it does not move from 0km/h


Thank you for reporting the issue with BH Fitness treadmills showing 0 mph after pairing - I’ve raised this to our team and they are currently investigating the issue.

1 Like

this problem was due to the update, to solve this, zwift must detect the treadmills exclusively as a speed sensor
while detecting our treadmills as a multiple sensor does not detect the increase in speed

I have the same problem.
I have a BH i boxter plus.
I can select the treadmil as an a running sensor, the polar H10 as a heart rate sensor and the select a route for running as usual but the avatar doesn’t move at all. Is always at 0 km/h.
Is going to be solved in any future update?

Hello everyone

Zwift have been working on this issue with the engineers at BH Fitness, who have released a firmware update for the treadmill.

  1. Please contact BH Fitness support to update the treadmill’s firmware / software.
  2. Update Zwift to game version 1.66 or newer.
2 Likes