Companion App Not Showing Workouts [February 2023] [3.43]

I use the iOS companion app.

I was doing a cycling workout today.

The iOS companion app crashed.

On relaunch, it showed an incorrect workout. The workout was presumably someone else’s. It was the wrong type (running), name, duration, everything.

Yeah, I also got this again today, it’s completely broken.

Was doing a Zwift Academy cycling workout, and the companion app stays on this:

Have Zwift confirmed they know about this issue?

I haven’t seen anything that would indicate Zwift has acknowledged this issue. Yesterday I deleted Zwift from my iPad and ZCA from my phone, downloaded everything again and I was able to get the workout screen to function properly. But it isn’t consistent and I haven’t tried today (Thursday Feb16)

I just wrote an email to Zwift Customer Support about this, so we’ll see if anything happens?

1 Like

This support response was shared on a different thread

Same exact issue here. My girlfriend and I both have the same issue with companion showing a running workout screen when starting a cycling workout. Killing the app and restarting it multiple times will eventually result in the correct cycling workout screen. Happened again today Feb 19. Very annoying.

+1 here. CA randomly refuses to display the steps during workouts. Working solution for me: restarting CA, if necessary multiple times… :man_shrugging:

I had this occur yesterday with a Zwift Run workout so I tried loading everything again but this time I opened the ZCA first and then opened Zwift and selected the workout I wanted to do - and it worked fine. May have been a fluke but it’s worth trying.

When i do meet up’s and a workout from TP, The workout isen’t coming up og Companion.
Is it only me?.
It did before The last upgrade.
Tryed support. Bur they don’t understand.


This i mean.

But it works on wourkout, but not in meet up’s and workout

Hey all - this bug has been fixed with Companion app v 3.44. Please update at your earliest convenience, and bear in mind that it may take several hours for Apple and Google servers to update worldwide.


Thank you, Shuiji. I tested today and the issue has not manifested so far.

Thx Shuji! :grinning:

Awesome, thanks.

No its not. Stil not work on meet ups

1 Like

This is not showing up in companion when we do meet up`s and wourkout.
But when i do a workout i any route on zwift, it shows
somebody els having the same problem?

1 Like

Unfortunately it is still not working. I have updated iOS app to the latest version and still no workout on my companion app during ride.


Does your Companion app go into Game mode at all? That is -when you’re Zwiftting, does the Companion app switch from the image on the left to the image on the right?

If it goes into Game mode - please select any workout from any training plan. Then on the Companion app, please to go the Workout tab. If you’re not seeing your workout power / cadence target numbers - please take a screenshot. We’d like to see what you’re seeing on the Companion app.

OK @shooj :slight_smile: Thx for quick reply. I will check it today as advised and let you know about results! :slight_smile:

Well, it seems that Companion app doesn’t go into Game mode at all. See attached screens

The ride started at 2:00 PM and as you can see (last two print screens from 2:03 and 2:39 PM) Companion doesn’t care about it :wink: I don’t know if it is important but Companion was working perfectly on my iPhone 11 Pro. As soon as I changed it to iPhone 14 Pro it ignores each ride consequently. Both devices, laptop and phone are in the same wifi with no any restrictions or changes in its configuration. iPhone 11 Pro was working with laptop in this network perfectly.

1 Like

I did a workout yesterday in a meetup and in ZC, he workout dashboard never came on. ZC did go into game mode (the regular screen). In a regular free ride the workout dashboard would come on. Thanks