Companion app no longer adding events to calendar

Different issue I believe: Android 12 Zwift Companion app crash [3.32.0] [February 2022 ] [SOLVED]

Brought it up here because it’s related to the broken reminders. Was checking to see if that had been fixed (since Zwift stopped posting changelogs for CA updates) and hit the crash bug.

They still haven’t fixed the reminder settings, tho.

1 Like

latest update on android seems to have broken the notifications for a favourite started zwifting for good measure. fix one thing, break 2…

Working fine on my Samsung (Galaxy A71) Android (11) post update.

I’ve found that going into a specific category’s “details” page (rather than from the event’s page, with all the categories listed), then adding myself to the event will add a calendar entry to my phone from the companion app.
Events list → Event in question → Add button next to the specific category = No calendar entry added

Events list → Event in question → Select the specific category → Add button from this screen = Adds a calendar entry:


Good find, should help the devs debug it. Not much quicker than adding the reminder manually though. :wink:

@Lucas_M Is this issue being worked on?

1 Like

This is an issue that we’ve had our eye on and our dev team is working on with hopes to get released soon.

1 Like

Thanks. :+1:

FYI, the “set as default” button doesn’t work either, it constantly turns itself back off and the settings don’t save (when adding an event to your calendar).

Actually, the button to set default does work. You can check in the app settings->notifications and it will match what you select as a default in the dialog.

The problem is, the setting for creating reminders seems to be getting ignored. If it’s set to “Ask,” it doesn’t, and if it’s set to “Always,” no reminders are set.

1 Like



1 Like

Still the same on the latest update.

I discovered a workaround for this by accident yesterday.

If you go into the category itself, and sign up from there, the reminder and calendar event are set. Even if it’s a single category ride, if you tap the category section, so it loads the page w/ the signups, and tap the :heavy_plus_sign: there, instead of just doing it from the event, it obeys whatever settings you have.

Yeah Colin spotted that above. :+1:

Wonder if this one will make a year. Seven months down!

Dang. I missed that update, or I would’ve been doing it for months now!

I’ve always had issues with the Companion failing to put entries into my Google Calendar. It fails more often than not, but sometimes succeeds, for no obvious reason. Sometimes I’ve fixed it by successively subscribing to an event and unsubscribing again, till it worked. At the moment, nothing seems to do it. There was a time when Trey’s workaround of going from the overall event page to the category page for the event helped, but not at present. This on several devices including my current Samsung tablet and Pixel phone, but it happened on my previous ones too. From the hint in this thread, I’ve also just tried revoking permissions, restarting the app and reinstating them, but that didn’t help either.

It’s been broken almost a year at this point. Ridiculous really that existing features can just disappear and be forgotten about. Surely fixing inadvertent errors should take priority over new stuff.

Anyway you just have to do it manually, join the event then click the little alarm clock next to the time beneath the green/white tick (it’ll be greyed out).

I don’t think that works for me either, in terms of getting the ride into my calendar. Nothing does.

1 Like

I use a Samsung phone and tablet and, if you open up the participant list for the event and category of interest, and then join the event from there you should hopefully have everything added that you ask for.

I did have a problem creating calendar events when i had the Samsung Calendar app app disabled (actually not possible, so i revoked all permissions), preferring to use the Google Calendar. But you can’t set the Google Calendar as default, so calendar event creation accomplished nothing as the events went into a black hole. Once i restored Samsung Calendar permissions, instead disabling notifications from it, my Zwift events appeared, to then be synced with my Google Calendar, which i do use and from which i get my calendar notifications.

Thanks - this was really helpful. I don’t have the exact problem you described, but it does relate to Samsung calendar. I don’t use that app - I use Google. And I don’t even see the Samsung app normally - it’s not in my tablet’s list of apps, possibly because I’m using a third-party UI. I don’t care because I’m happy with Google.

But I managed to get in and see that the events are indeed going into the Samsung calendar. Grrrrr. Talk about unnecessary complications. What makes it worse is that my Pixel phone still isn’t reliable at getting Zwift events into the calendar either, probably because of the effect described in this thread where registering from the participants’ page works better.

So, the summary for me is (1) Never register on the tablet, because it’s broken by Samsung, and (2) On the phone, register on the participants’ page.

We’ll see how that goes. It’s working at present.

And yes, I’ve seen several pages saying how nice the Samsung calendar UI is. But I only need good enough, which Google is, and I don’t have the spare time to figure out how to fix the functions broken in order to get an unnecessarily-nice UI. I just don’t care. I want it to work as simply as possible, which means no junkware apps, at least unless they are optional. I may buy something else next time…

Rant over. This page may help other Samsung sufferers, though it didn’t help me: