Companion App Grayed Out

Zwift has been working just fine until the last Apple update or Zwift update both happened about the same time for me. Now my Wahoo Kickr Bike and my Whoop are not being seen. My Wahoo App shows my bike and headwind unit. So I am sure the iPhone running 16.2 is not the issue. But now when l launch Zwift on my iMac the Companion App feature is grayed out and will not allow me to connect. I also tired on my MacBook Pro and Apple TV all with the same results Companion App grayed out and not connecting. I can log into the router and see that all devices are running on the same WIFI network and have IP address within my IP range. Even tried loading Zwift on my wife’s older iPhone 11 with the same results Companion App grayed out when you launch Zwift on another device.

Make sure your companion app is running and is on the same network as Zwift. Usually having them on the same WiFi router will do the trick. Same thing happens to me if my iPhone running companion connects to the WiFi on the other side of the house.

SOLVED: This is going to happen to more users who have apple products and Xfinity new route XB7-T it will prevent there companion app from connecting. here is the fix.

Configure Device Discovery or Universal Plug ‘n’ Play

  1. To configure device discovery, connect to your WiFi network and access from a web browser.
  2. Once logged into the Admin Tool, navigate to Advanced > Device Discovery.
  3. You may see UPnP default to being enabled, which automatically opens ports for appropriate applications and services for UPnP-capable devices on your network. You have the ability to disable this in the Admin Tool.

You also have the ability to enable Zero Config , which is a discovery protocol that allows UPnP-capable devices to connect automatically.