Can't get Hammer to Pair


(John Zinckgraf - PVC) #1

I’ve got a new cyclops hammer and can successfully pair the Bluegiga Bluetooth dongle with Rouvy, but when I open zwift and search for devices it does not see the trainer. Any ideas? I’m running Windows 7.


(Paul Allen (Watopia Wayfinder)) #2

You need to either use the Zwift Companion App to bridge the Bluetooth signal to the PC or an even better option is to get an ANT+ dongle and a USB extension.

You cannot directly connect a device using Bluetooth to a PC for use with Zwift


(John Zinckgraf - PVC) #3

Ok. I was able to get companion app to work, but assumed the giga bt would work direct. Cyclops should be more straight about it since they infer you can go direct. I guess you can direct with Rouvy but not zwift. Why not? Is it because zwift doesn’t support the direct connection. I went with bt over ant because online reviews suggested bt was better at connection then ant.


(John Zinckgraf - PVC) #4

Even with companion app when I go to pair in the zwift computer app I still don’t get connection to trainer.


(John Zinckgraf - PVC) #5

So bottom line, giga bt only works with Rouvy but not zwift even if I use companion app?


(Paul Allen (Watopia Wayfinder)) #6

With Bluetooth you need to make sure that the trainer is not connected to any other app or device (this includes your phone) beforehand opening Zwift. Also if you are using an iPhone make sure in the settings of the ZCA that Bluetooth is turned on.

In my experience ANT+ is a more robust connection and much less of a hassle to get devices connected since the protocol allows many connects, not just on like Bluetooth.


(Paul Allen (Watopia Wayfinder)) #7

To connect Bluetooth devices to a PC your only option is to use the Zwift Companion App to bridge the signa.


(Paul Allen (Watopia Wayfinder)) #8

You also need to make sure the the PC and your phone are connect to your router, either WiFi or cable will work.


(John Zinckgraf - PVC) #9

Thanks. Last question. Why the need to have phone and computer on wifi? My phone is, but the computer is running through Ethernet cable.


(Paul Allen (Watopia Wayfinder)) #10

The phone can be on WiFi and the PC can be connected via cable, that’s the way I do it.


(John Zinckgraf - PVC) #11

I’ve tried opening zwift, then the companion, then turning bt on my phone on. No luck. I ordered ant dongle but it shouldn’t be this frustrating


(Paul Allen (Watopia Wayfinder)) #12

You have to leave Bluetooth turned on on the phone.


(John Zinckgraf - PVC) #13

Paul, do you know how to change power setting in Rouvy to dial down the resistance of the hammer? I see a setting for “simulator power n/a” but I cant change it.