Big FPS drop in full screen mode

I’ve noticed my PC (fairly basic PC - not a gaming rig) is putting out low FPS around 30 in Ultra mode. I’ve tried a few tweaks to the graphics card but because it’s quite weak it’s made negligible difference to FPS, and occasionally it might peak at 34.

However today I tried turning off full screen mode just as a test and straight away the FPS jumped to 50 with an avg of 45.

Is there any reason why this should happen, doesn’t seem logical. Obviously happy to run it out of full screen mode but prefer the uncluttered full screen mode.

Any tips or guidance gratefully accepted.

If find that windowed mode works better then try downloading borderlessgaming (find it on google).

2 Likes

Thanks Gerrie, I’ll look into that.

I was at the point of switching out the GPU for a 1650 OC as I thought it might give me some extra smoothness, but it doesn’t offer much over the 1050Ti. As the PC is small form factor it only has 220w PSU and no additional power cable for an up spec GPU with 6/8pin so I’m clutching at straws unless I want to upgrade the PC.

Here’s three things to try one at a time:

  1. If you haven’t, try the drivers from geforce.com and do a custom install do not install GeForce Experience, HDMI audio, 3D, etc if you don’t need it. You could be using base OEM or Windows drivers that are limiting performance.

  2. Drop down from Ultra to High graphics.

  3. Try Zwiftalizer’s graphics tweaks https://blog.zwiftalizer.com/post/confighacks/

I get ~90 fps with old hardware… i7-920 and GTX 970 on 1080p High using all three things above.

1 Like

I managed to bag a cheap GTX1650 OC card and whacked it in the PCIE slot. Now bear in mind this graphics card is 2 years newer than my previous GTX 1050Ti.

I run a session of Zwift, check the logs and I notice the default graphics setting has switched from Ultra to High??? So a newer graphics card has prompted a retrospective drop in setting. The only good new in that is that the max FPS was 122 with the avg at 95, but given those values I’m surprised Zwift hasn’t offered Ultra mode.

I’ve now switched off the vertical sync, set the graphics to external GPU only, and done some optimisation of the drive.

Not a big issue as the on screen graphics still look very good, but just not the result I expected. At least the framerate is in the ballpark of where I was expecting which is a step forward as I’m not seeing the on screen surging I was getting sub 30fps.