AutoCal on Swift Hub is wonky

I like the feature. HOWEVER… Everytime I ride, not just when I move or unplug the Hub, I have to autocalibrate. This means pumping ~350w for several minutes while the screen shows that I’m doing ~50w. It takes a lot of energy to get to 10mph to launch the autocal - and it usually take 3-5 attempts to get it to take. I’m snockered before I’ve even warmed up. Why can’t it keep my previous setting until I move or unplug the Hub?