Zwift Companion can't add Garmin Connect service [December 2021] [v3.29]

I can’t actually add Garmin Connect to my Companion App. I disconnected it a few days ago to try and resolve the sync problem hoping to add it back. Now it won’t let me. I push the orange + and nothing happens.

Hi @Fiona_Bitters
Thanks for that report - I’m seeing that you’re on the latest (v3.29) version of Companion for Android. I’ll flag this up to the team.

What happens when you update your third party connections via the website instead? Instructions for that are on our Support Hub

It doest give me the option on Garmin Connect. Zwift isn’t one of the available Apps. It was on there prior to me disconnecting everything to try and resolve the sync issue.

You need to do it from Zwift, See the link posted above.

on the zwift website: The at Home Cycling & Running Virtual Training App

1 Like

On Zwift . com it let’s me connect but I then just get the spinning wheel that indicates it is trying to connect.

did you try a different browser, and tried to log into Gamin connect on another tab.

1 Like

@Fiona_Bitters
We confirmed this does not work using the Companion app (both iOS and Android). Thanks for bringing it to our attention. It is already on our to-do list.

We verified that the website method using the instructions I linked above does work. If you need one-on-one assistance, my colleagues can dig into it with you. Please use the Contact Us link on support.zwift.com.

1 Like

I used a different browser and it worked. Thanks you for the help.

1 Like

That worked thanks.

3 Likes

That’s good news.

Ride on. :ride_on: