Workout mode menu glitches


(Ron Sines [odz] B) #1

The menu in workout mode is confusing and hard to navigate for me.  On one of my computers I have been unable to get to the sub menu in the workout plans, I click on the arrow and it doesn’t respond.  So I switched to my laptop to see if I could get it to work on there.  I did manage to get all the sub menus to open up but if I clicked on the left of one of the “days” in the menu it said to select one of the workouts to the left or select none at all.  There is nothing to the left for sure and clicking on the button to the right it pulls up different workouts sometimes depending on where you click on that button.  

Some of the sub menus list days 1-7 but if I click on day one to see the workout it might say “optional day 5” or if I click further along the button for that day it brought up day 3 I think.  Also sometimes the buttons light up blue when you click on them and sometimes they don’t.

Anyway I could submit a ticket and take some pictures to clear up what I’m running into, but for now I’m just checking to see if this is a known issue or just something on my end.


(Jon Mayfield) #2

We’ve got this fixed here at Zwift and will release an update very soon to address the issue.  Sorry about that.


(Ron Sines [odz] B) #3

Thanks John, I was surprised by how much content was in this first release of the workout mode with all the rumors that it was going to be very minimal at first.  Can’t wait to see it working as intended.  :)


(John Baker) #4

I, for one, am glad to see responsiveness to issues.