Why is G-Sync Capped at 60FPS?


(Mark Cane (C)) #1

Up until recently I’ve been happily running Zwift using a G-Sync compatible Acer Predator Monitor.  I altered the config file to display the FPS from the GTX980 graphics card and compared that to what the monitor was displaying.  The two would change in sync, showing that the G-Sync was working.

Recently, the behaviour in game changed so that the maximum FPS displayed by the monitor was 60!  To confirm I hadn’t messed anything up inadvertently, I ran the Unigine Valley demo which confirmed that G-Sync was working fine with that.  Hence the issue is related to Zwift, not my hardware.

I am running Zwift in full-screen mode to match the G-Sync requirements in the Nvidia Control Panel, and also ensured that I run the game on the primary display.  I’ve even disabled my other displays to confirm the same behaviour.

When firing up Zwift the monitor frame count immediately switches to 144Hz, as it always does, then once it’s loaded and the game starts drawing graphics it changes to a low variable count for the first couple of seconds, matching the card, but as soon as the card gets up to speed and exceeds 60Hz, the monitor remains capped at 60.

Any idea what’s going on?  This is very frustrating given that I spend a lot of money on this G-Sync monitor exclusively for use with Zwift!  BTW, there’s a noticeable difference in smoothness at high frame rates so I miss this feature.


(Tom Olinger) #2

Mark,

I came across your post when searching if anyone was using a g-sync monitor with Zwift. If you haven’t found a solution you might see if the suggestion in this unrelated forum post fixes your frame rate issue.

Tom

https://rog.asus.com/forum/showthread.php?54825-BF4-Maxing-out-at-60FPS-with-G-Sync


(Mark Cane (C)) #3

Thanks Tom, that’s very useful!  I had capped my monitor to 120Hz since 144Hz makes me feel sick during normal use.  This is probably because it’s not an even multiple of the UK mains frequency (60Hz).  However, changing it to 144Hz has removed the 60Hz cap when using GSYNC in Zwift and the graphics look silky smooth again!

I’m just going to have to change it manually whenever I use Zwift.

Mark