Trainer Difficulty setting reverts to maximum [October 2022]

The Trainer difficulty does not affect flat routes and there are many flat routes out there. don’t be tempted to sprint on the flat routes as that will not be good for recovery.

1 Like


zwift broke something, the workaround is to only use certain aspects of the game but still pay full price!

Seems fair.

1 Like

I have found how to reproduce the fault and clear it.

I normally ride with an Android phone - that is the only device that I pair with my Kickr bike. Occasionally I log onto the PC application (which has never been paired to any trainer) just to look at stuff on a bigger screen.

If I uninstall the phone app, then install it, set the difficulty, and JUST use the phone app - then all is good. The difficulty setting remains where I put it.

If at any time I log onto the PC app, then the next time I use the phone app again it will have reset the trainer to max, and cannot thereafter be changed.

So for me it works fine so long as I perform a clean install onto the phone, and forget the PC app exists.

(I have repeated this loop multiple times to test it. It is as though Zwift are storing something server side that cannot cope with the fact I have different number of settings on PC and phone)


This is very good information @Andy_C4 .

I am sure the developer team and @Rowdy would find this very useful.

Software developer for 30+ years before retiring


I can’t believe this hasn’t been addressed in 1.32. This was known about 6 weeks ago… It is also a reoccurring problem from last year too… to be told I can only do the flat rides in Zwift and not have this addressed is very poor software development IMHO… just get it fixed please Zwift, I don’t want to see any new features released until the existing ones work… is that too much to ask?


Unfortunately I only use an android, Samsung S22,. Deleted the app. cache etc and reinstalled last night but no joy. As I type, Zwift support have just let me know about a new (small) update as of last night. Fingers crossed when I try it out tonight it actually works!

Hello all,

This issue was addressed in 1.32.0, but it looks like it was not fixed for all affected Zwifters. I understand how frustrating this must be. I’m raising the issue back to developers immediately.


Hi Rowdy - thanks for the email… I do apologise I jumped too quick when I saw Shuji’s comment that this issue hadn’t been addressed; I took it at its word. As you have asked I have connected my device to the trainer and can confirm that the Trainer difficulty does seem to be fixed, along with the volume sliders. I have not ridden a full ride but I have saved my settings, ended a ride and gone back in after re-pairing and the difficulty level is no longer stuck at 100%… thanks for sorting this and apologies for not seeing it for myself… BTW for anyone else I am using a Samsung S20 Ultra

Just tried again tonight and the slider is no longer fixed at max. :slight_smile:

Hi all,

Thank you for double-checking the fix. I’m going to mark this as solved for now. Please let us know right away if you are unable to adjust trainer difficulty after updating to 1.32.0. Thank you so much for your patience.


you can pause Zwift in your account ?

My trainer difficulty can be adjusted. Sort of. Only the effect is zero. Trainer difficulty is permanently zero in game. I have a Truetrainer. PC or iMac both the same problem. Before this update no problem.

Hello @I_Sidorus , this doesn’t sound like the same issue in this forum thread. We’ll be happy to help troubleshoot in the support center.

Hello @I_Sidorus , this doesn’t sound like the same issue in this forum thread. We’ll be happy to help troubleshoot in the support center.


I have already reported this problem at Truekinetix.
I am not sure where the exact origin of the problem is situated.
Riding on my Truetrainer since the last update is possible without ANY shifting. I could easily read a paper while riding. Checking the trainer difficulty learned that it had to be 50%. I moved it to 100% with no effect at all. Riding on my wife’s Kickr bike was quite different. There the gradient changes made shifting necessary. I then changed my iMac for her PC, but that made no difference. So it is a problem of the Truetrainer since the latest Zwift update. It is now degraded to a (very) dumb trainer unfortunately. For me no fun at all. I like hill’s.

hello rowdy my samsung s21 ultra and s6 tab experiencing the same thing can’t connect with bluetooth but in apple device like iphone and ipad can connect.
This has been happening since December, nothing happened before

Hello @Genesius_Ivan , this sounds more like a bluetooth connection issue than a trainer difficulty setting issue. If you recently upgraded to Android 13 OS, this may be due to an issue that some Samsung users have reported since updating their OS. We’ll be happy to help troubleshoot if you’d like to open a support ticket!

Thank you for your response, so the problem is android 13 right?can you have trick to solve this problem?

1.33 has a fix for this issue. Try it and see if it works for you.