Surface Book i7, GPU, loaded


(Jim Linck) #1

I have a very fast Microsoft Surface book, highest end, with i7 and GPU, etc. Very fast on everything I do… except Zwift. Video is so choppy it gives me a headache, unusable to me. Is there something I am missing?


(Jon Mayfield) #2

The problem is that the graphics driver reports the GPU as being a “GeForce” without a specific model number, and another manufacturer does the exact same thing but they put a graphics adapter in that’s 10x faster.   Zwift thinks you have a high end GPU and scales up detail accordingly.

I think I can sort out a workaround in the next update for this, but I have no idea how much faster it’ll run.  I’ll reply to this thread whenever that update goes out.


(Jim Linck) #3

Thanks. The Surface Book has a pretty high-end GPU, but I guess it doesn’t matter given your scaling. I tried Zwift on my Surface Pro 4, which doesn’t have a fancy GPU, and is slower than the book, but still pretty fast, and it worked fine (although I am having a hard time getting it to talk nicely with my KICKR, and I sure wish it was bluetooth instead of relying on ANT+).


(Jon Mayfield) #4

It’s high end for a thin battery powered device for sure, but the GPU is only about 10% as fast as the gaming GPU you can get for desktop computers right now.   Zwift detecting the proper amount of stuff to send to it is pretty critical. :slight_smile:

I’ve put in a work-around that I can’t test (as we don’t have a top of the line surfacebook here), but it’ll be in the next update and it should bump the frame rate up.  I’ll check back with you then.  


(Jim Linck) #5

Thanks. I appreciate your efforts. I sure want it to work as my brother says it’s cool, but i just couldn’t deal with the choppiness. As I say, though, it seems to work on my pro 4. Sadly my trial ends tomorrow so I will have to make a call (yes, that is a plea for a couple more days trial :-). 


(Charles G) #6

I just tested today on my surface book i7 today with V 1.0.9609

Quality is amazing, FPS is great.

 

THANK YOU ZWIFT DEVs YOU’RE THE BEST.

 

It works much better than my desktop pc. I switched to 1080P and it looks sharp sharp, no flickering and shadows are all working.

 

SMOOTH.


(Titan Miller) #7

It works now! Thanks Jon! One quick question though…why not allow the user to choose their quality settings like most games? Zwift doesn’t exactly require super high FPS like an action game. I’d rather have 15fps and higher quality.